Jump to content

Disappointed with the HyperX Cloud Headset.

 Share

hello,

 

I have posted a topic about the HyperX Cloud gaming headset before (Troubleshooting), but now I am pretty much 100% sure I will return them.

These are the problems I'm having with them:

- sound goes through the headset and picked up by the mic

- from my experience, people in my Skype call can hear what I'm watching as if they are right next to me.

- the mic picks up the sound faintly at first and then gets louder.

- there is a static sound coming out of the headset which is apparently VERY annoying (my friends on Skype said that).

- when I asked for help from the Kingston HQ, the told me to raise the mixer volume up..... wtf. it only made things worse. the sound picked up by the mic got even louder.

- on my troubleshooting post, another member of this site said he has the exact same problems.

 

as soon as I switched back to my Turtle Beach PX3's, all of these problems got resolved. so this confirms its a problem with the headset itself.  <_<

Link to comment
Share on other sites

Link to post
Share on other sites

Probably a factory defect/bad production.

My Current PC Codename: Scrapper

Spoiler

Intel i5-3570 | Some LGA 1155 MOBO Some Generic DDR3 8GB 1600Mhz | PowerColor RX 560 2GB | Recycled HP Case Crucial MX100 128GB 1TB WD Blue 7200RPM | Some Generic 500w PSU | Intel Stock Cooler

Link to comment
Share on other sites

Link to post
Share on other sites

Happened with my Razer kraken and about after a month it completely stopped playing sound through the mic. It might be just because its new, plus you should use Teamspeak as Skype sucks imo

PC Specs:


CPU: i5 4670K  4.5 GHz  | CPU COOLER: H80i | GPU:EVGA GTX 780Ti  |  Motherboard: MSI Z87I   |  Case: Bitfenix Prodigy  |  RAM: 8GB Avexir Venom  |  HDD: Seagate 1TB , 60GB Agility 3  Monitor: 32" HD TV (LOL)   PSU: Corsair 750W

Link to comment
Share on other sites

Link to post
Share on other sites

Happened with my Razer kraken and about after a month it completely stopped playing sound through the mic. It might be just because its new, plus you should use Teamspeak as Skype sucks imo

I'll see what the Kingston HQ say tomorrow. they are from Europe so they respond over night in my case (I'm in Canada). if we can't resolve it somehow, that's goodbye to HyperX Cloud.

Link to comment
Share on other sites

Link to post
Share on other sites

hello,

 

I have posted a topic about the HyperX Cloud gaming headset before (Troubleshooting), but now I am pretty much 100% sure I will return them.

These are the problems I'm having with them:

- sound goes through the headset and picked up by the mic

- from my experience, people in my Skype call can hear what I'm watching as if they are right next to me.

- the mic picks up the sound faintly at first and then gets louder.

- there is a static sound coming out of the headset which is apparently VERY annoying (my friends on Skype said that).

- when I asked for help from the Kingston HQ, the told me to raise the mixer volume up..... wtf. it only made things worse. the sound picked up by the mic got even louder.

- on my troubleshooting post, another member of this site said he has the exact same problems.

 

as soon as I switched back to my Turtle Beach PX3's, all of these problems got resolved. so this confirms its a problem with the headset itself.  <_<

Got that problem with my Vengeance 1400's I tell them to suck it up most of the time but usually turning the volume down helps.

Gaming Rig - Excalibur - CPU: i5 6600k @ 4.1GHz, CPU Cooler: Hyper 212 Evo, Mobo: MSI Gaming M3 RAM: 16GB Corsair @2400MHz, GPU: EVGA 1060, Case: NZXT Phantom Full Tower (Red)

My Virtualization Server - Dell R710: 2x X5570s @ 2.93GHz with 32GB DDR3 RAM [Web Server, OSX, Plex, Reverse Proxy]

I love computers, gaming, coding, and photography! Be sure to quote me so I can respond to your post!

Link to comment
Share on other sites

Link to post
Share on other sites

Should have bought a Audio technica......

† TTCF Member † Jesus loves you! Have a good day and stay techie!

Link to comment
Share on other sites

Link to post
Share on other sites

Should have bought a Audio technica......

no thanks... $300 on a headset is a waste.

Link to comment
Share on other sites

Link to post
Share on other sites

no thanks... $300 on a headset is a waste.

should have bought headphone+microphone combo. Would have been much better for around the same price.

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

should have bought headphone+microphone combo. Would have been much better for around the same price.

I might. I still have 30 day warranty with newegg so I will get all of my money back. I might as well just buy another headset. I want it to be a two-in-one.

Link to comment
Share on other sites

Link to post
Share on other sites

should have bought headphone+microphone combo. Would have been much better for around the same price.

This is what i meant, MH30's40'sor50's and a modmic

† TTCF Member † Jesus loves you! Have a good day and stay techie!

Link to comment
Share on other sites

Link to post
Share on other sites

- sound goes through the headset and picked up by the mic

- from my experience, people in my Skype call can hear what I'm watching as if they are right next to me.

 

try to play with amplification levels. I had that problem with several headsets

 

- there is a static sound coming out of the headset which is apparently VERY annoying (my friends on Skype said that).

 

that is either feedback or a freaking unshielded cheap crap. Similar shit is going in with Cyborg/MadCatz F.R.E.Q. series.

 

- the mic picks up the sound faintly at first and then gets louder.

 

seems like the Skypes' auto-level - turn it off.

 

- when I asked for help from the Kingston HQ, the told me to raise the mixer volume up..... wtf. it only made things worse. the sound picked up by the mic got even louder.

 

you know, pretty much every single support that I contacted was just a monkey with a keyboard. they were not helping at all :angry:

 

- on my troubleshooting post, another member of this site said he has the exact same problems.

 

Typical <_<

 

This is what i meant, MH30's40'sor50's and a modmic

 

This.

I would go with 50s, because of the build. Sturdy, less plastic, more metal(stainless steel, I think).

 

That's the setup I personally aim for. But I will have it only when my friend is coming from France. Price difference is over 50 euros *facepalm*

Link to comment
Share on other sites

Link to post
Share on other sites

The description you gave sounds like your daily Razer product. Either you have a really bad soundcard in your motherboard, have bad Windows settings or you've got a faulty product. Which is for you to find out.

 

Good luck. 

GAMING RIG: Fractal Design Node 804 - Intel Core i5 4460 (Haswell refresh) Sapphire R9 280X 3GB OC 2x4GB HyperX 1600MHz Samsung 840 256GB Gigabyte B85M-DS3H

GAMING GEAR: Ducky Mini (MX brown with white led) Steelseries Sensei RAW Steelseries QCK+ Kingston HyperX Cloud

 
Link to comment
Share on other sites

Link to post
Share on other sites

I've got the QH-85 (open design -> more sound leaking) and tbh.. the mic, indeed, isn't the best there is but I don't have any of those problems.

Try to set everything up correctly for the mic and your sound and then it should be just fine. You can always get a nice decent separate mic and don't use the mic from the headset at all. 

Link to comment
Share on other sites

Link to post
Share on other sites

This is a common problem with all gaming headsets which is why many people recommend a headphones + mic combo instead.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×