Jump to content

Raspberry Pi 4 not connecting to WiFi after connecting to ethernet.

I have a problem with my Raspberry PI 4b of it not connecting to the internet through wireless. I was trying to run a Minecraft server on my raspberry pi and needed as fast of an internet connection as possible. I connected directly to the ethernet port with a cable from the touter.


Now when I unplugged the ethernet cable the Pi keeps trying to connect to the home WIFI, but when I check on the connecting process by hovering over the WIFI indicator, the little popup tag says "associated with (my home WIFI name here)", and it will never stop saying that.  


Can anyone suggest possible fixes other than reinstalling the OS?  I'd like to fix the issue without having to reinstall the OS for a variety of reasons.  The WIFI worked fine before I plugged in the Ethernet cable and then it hasn't worked since. 



Link to comment
Share on other sites

Link to post
Share on other sites

20 hours ago, Tubaplayz said:

Can anyone suggest possible fixes

Delete your wireless newtwork settings from /etc/wpa_supplicant/wpa_supplicant.conf

In terminal run this command

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Delete the section that looks like this

ssid="your network name"
psk="your netword password"

Once done either restart the pi or try restarting the network service

sudo service networking restart


You should now be able to reconfigure the wifi from the desktop

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now