Jump to content

Hmm... My monitors keep doing this (Dead/glitchy pixels?)

Well I decided to ask here because I'm not sure what's happening here but my monitors keep doing this for no reason? Not sure what to call this and I haven't found anyone else with this problem yet. This is my monitor in the pic & the pixels are broken around the middle and it sucks alot (the edges are fine). When you turn it off, it looks normal but when it's on, the pixels are like this. Does this have to do with the backlight? My other monitor was also like this. Both of them were fine at the start but after awhile both got this exact problem and can't use my monitors properly. Not sure what's causing this for both of them since they're from different brands & models... (One from Samsung & one from Dell)

 

P.S. These monitors are pretty old too, released a long time ago. (You can see how the edges are very fine compared to the middle in 2nd pic, much less grain/noise?)

16704267911099108977749009554718.jpg

16704268759023435582840702104581.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

Did you plug them into a different machine to comfirm its not the computer thats broken?

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×