Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Xbox (App) Issue - CLiP license device ID does not match

MainVane
 Share

Hi guys,

 

First time posting in the community, hoping that I can get some help.

 

I just bought a new Gigabyte AORUS 15P and downloaded Forza Horizion 5 through the Xbox application.

 

When I launch the game I get an error

"C:/Program Files/WindowsApps/Microsoft.624F8B84B80_3.475.474.0_x64__8wek...\GameLaunchHelper.exe

CLiP license device ID does not match the device ID in the bound device license"

 

I've looked at multiple support posts on other websites and I can't seem to resolve this issue.

 

Thing's I've done

- Updated windows, all updates completed

- Logged in and out of both the Microsoft Store and the Xbox Application

- Removed unused devices on my Microsoft Account

- Unlinked unused devices on my Microsoft Account

- Ran the following on Powershell as per https://xbox-forums.com/threads/clip-license-device-id-does-not-match-the-device-id-in-the-bound-device-license-after.468116/ 

Get-AppxPackage Xbox | Remove-AppxPackage

Get-AppxPackage Microsoft.XboxApp | Remove-AppxPackage

Get-AppxPackage Microsoft.GamingServices | Remove-AppxPackage –allusers

 

I'm at wits end here, I have no idea what's wrong - anyone that can help me out?

 

Link to comment
Share on other sites

Link to post
Share on other sites

  • 1 month later...

Hi, I have the exact same issue - did you manage to solve this? Please let me know!

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×