Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

AMD 7970 UEFI/Legacy BIOS issue with Z77 mobo

 Share

I know this is some old gear but this is for a retroish game room I'm trying to get together. Really struggling with getting my Win10/XP dual boot machine up and running. Have a 2600k,  ASUS P8Z77-V LK, and a Sapphire Radeon HD 7970 Dual-X. No matter the settings I try to use in the UEFI I cannot get the motherboards BIOS to display through the 7970. The dream is to have a SSD with Win 10 installed and another one with XP installed and press F8 or whatever during boot to switch between them. Right now if I install Windows 10 using the iGPU and the motherboards onboard display port, shut down, switch to the 7970s output I can boot into Windows 10 without an issue, everything works great, still don't see the BIOS though. So I know the 7970 its self is not broken.  I believe the issue is some sort of UEFI/legacy  issue as my 7970 doesn't support UEFI. tuturoj.jpg uNXMITg.jpg[b[/b]]. I've tried every possible combination of settings with no changes in BIOS display. Sometimes it will break my Win10 install depending on settings and I gotta reset the UEFI settings to get it back to working. I did try to flash UEFI modded BIOS to my 7970 which is a thing people did 10 years ago but all I did was brick one of the BIOS on my card, thankfully it has dual BIOS so the card still works but I can't get any display out of the 7970 when set on the flashed BIOS. I see people online running 7970s and 2 and 3rd gen core CPUs without issues. I've tried booting from a legacy boot USB stick with no other drive connected but that still doesn't show up on my 7970. It's only once the computer gets inside Windows does it have video out. I haven't tired to get XP running yet. I'm not sure what is holding me up here. I also can't help but feel like the Asus UEFI is lacking settings, for example I can't disable the iGPU at all and no setting flat out says "Legacy BIOS".  I also flashed the mobo to the most up-to-date BIOS from the Asus website. I'd really like to stay with the 7970 for it's more feature rich XP drivers (GPU scaling and HDMI color settings), I can change the motherboard no issue if it's indeed a compatibility issue. Last resort is buying a GTX 960 which has UEFI support but doesn't have GPU scaling or HDMI color options under XP. Would really like to get up and running with what I have though. 

This is now multiple weeks of trouble shooting this and I can't even put into words how frustrating this is. If anyone could shine some light onto the issue i'd be forever grateful.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×