Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Weird issue with graphics card

Hello, 

 

I got this GTX 1050 ti I don't know the vendor but when i plug it into a pc (thinkcenter e73) the CPU fan's rpm goes to 100% and nothing is being displayed on the monitor furthermore no bios beeps as well. i did test the pc with another gpu to see if it worked and it does. Is there any possible way to fix this? i have a heatgun and isopropyl alcohol but i don't know how to use them to fix this i seen online people fixing gpus like this. Any suggestions would be helpful! +Plus is it normal for the 6-pin connector to be missing?? 

1634483159626.jpg

1634483159618.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

9 minutes ago, Rasil1127 said:

I got this GTX 1050 ti I don't know the vendor

for starters, is it even a 1050ti? 🤔

 

9 minutes ago, Rasil1127 said:

Plus is it normal for the 6-pin connector to be missing??

for 1050ti? yea

https://forums.tomshardware.com/threads/what-models-of-gtx-1050ti-comes-without-6pin-connector.2916025/

 

did you plug the display into the GPU?

My PCs: Desky | Beddie | Miney | Benchie

Things I need help with: (nothing at the moment)

Spoiler

none atm

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

Spoiler

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

Personal Blacklisted Companies:

Spoiler

Acer: shit tier quality products, shit tier customer service thus far, they "tried" to solve my issue but they arent really doing anything but delaying and delaying. (on-going case since July)

Gigabyte: horrible customer service (gigabyte had literally 0 customer service, asked me to go to retailer with NO WAY to email them about a question) but at least they fixed my shit in ONE MONTH (would probably take me 1 hour to fix if they let me email them)

XiaoMi Phones: built like a tank but the software is buggy as all hell

Seagate HDD: had too many dead seagate drives

Kingston SSD: 300V controller swap thingy

Razer (except their mouse)

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

 

Link to comment
Share on other sites

Link to post
Share on other sites

9 minutes ago, Rasil1127 said:

+Plus is it normal for the 6-pin connector to be missing??

1050Ti limit is at 75W, which is at the edge of pcie slot power limit, so yeah it makes sense.

 

11 minutes ago, Rasil1127 said:

the CPU fan's rpm goes to 100% and nothing is being displayed on the monitor furthermore no bios beeps as well.

Sounds odd, are you even sure it is legit 1050Ti not a wish.com scam special?

Remember to press quote to get a response from someone! | Check people's edited comments! | Be specific! Our answer effort is in proportion of your effort to write it! | React to your heart, not peer pressure!

 

"Wow, you want me to say ara ara? Really?"

- Clock Girl

Self Introduction and Current Rig

 

🏳️⚧️ Rights

Link to comment
Share on other sites

Link to post
Share on other sites

Quote

for starters, is it even a 1050ti?

It should be because it has a 1050ti die. i searched the numbers on google. (gp107-400-a1)

Quote

did you plug the display into the GPU?

Yes i did

Quote

Sounds odd, are you even sure it is legit 1050Ti not a wish.com scam special?

Im not sure if it is fake i got this from a lot on ebay

 

1634484470156.jpg

1634484470163.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

12 minutes ago, Rasil1127 said:

It should be because it has a 1050ti die. i searched the numbers on google. (gp107-400-a1)

if it's the right die then it should be fine

 

but if it's not even displaying the bios, and using another GPU on the system worked, then this gpu might be faulty

though i don't have any particular suggestions other than trying to send it for professional board repair, but not sure if a 1050ti is worth the hassle

 

return it?

My PCs: Desky | Beddie | Miney | Benchie

Things I need help with: (nothing at the moment)

Spoiler

none atm

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

Spoiler

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

Personal Blacklisted Companies:

Spoiler

Acer: shit tier quality products, shit tier customer service thus far, they "tried" to solve my issue but they arent really doing anything but delaying and delaying. (on-going case since July)

Gigabyte: horrible customer service (gigabyte had literally 0 customer service, asked me to go to retailer with NO WAY to email them about a question) but at least they fixed my shit in ONE MONTH (would probably take me 1 hour to fix if they let me email them)

XiaoMi Phones: built like a tank but the software is buggy as all hell

Seagate HDD: had too many dead seagate drives

Kingston SSD: 300V controller swap thingy

Razer (except their mouse)

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

 

Link to comment
Share on other sites

Link to post
Share on other sites

It's a Lenovo OEM GTX 1050 Ti.

 

Maybe you have to update the motherboard BIOS before it's compatible.

Link to comment
Share on other sites

Link to post
Share on other sites

Quote

Maybe you have to update the motherboard BIOS before it's compatible.

Okay ill try that ill let you know if it works 

Link to comment
Share on other sites

Link to post
Share on other sites

I just updated the bios the problem is still there.. more info: the gpu die doesn't get hot when plugged in and the fan doesn't spin 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Newegg

×