Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Netgear Orbi refuses to allow Google Devices on network

Hi everyone!

 

I have recently upgraded our previous home internet setup (previously just using ISP provided router) to the Netgear Orbi RBK13 AC1200 Mesh WiFi System.  Overall, we haven't had any major issues until we have gone and tried to connect a range of smart devices, specifically Google Home devices, to the network.

 

Whenever I attempt to connect any of the Google Devices by:

1. Plugging it in, letting it power up for a few minutes

2. Opening the Google Home App on a device connected to the WiFi

3. Selecting the Google Device in the App through the 'Set up xyz' button at the top

4. Accept the prompt to 'Set up xyz device'

The device will either fail to let my phone connect or, on selecting the Orbi Wifi, will then prompt me with 'Could not communicate with your xyz'.

 

I have tried using several devices both to set up, and be set up to avail. Keen to hear any advice you might have!

CPU: Ryzen 5 2600 (2.7GHz) | Cooler: Noctua NH-U14S | Motherboard: Asus Prime X470-PRO

GPU: Gigabyte GeForce RTX 2070 Super Windforce OC 8GB | RAM: Team Dark Gray 32GB DDR4 3200MHz | Case: Fractal Meshify C

PSU: Corsair RM650x Gold 650W | Boot SSD: Samsung 970 EVO Plus M.2 500GB | HDD: Seagate Barracuda 2TB & Seagate Barracuda 4TB

Link to post
Share on other sites

I've never had any luck with Netgear kit. In my experience it's always unreliable, buggy, and prone to failure. Can't say that's necessarily your issue here, but I also wonder how much worth there is in trying to debug it when it would be much easier to box it up, return it where it came from, and get something that does work.

 

I just installed a pair of TP-Link Deco X68s in my home. Setup was nothing. Everything just worked flawlessly, and my 3 story home is blanketed in WiFi. I'm not particularly a fan of their app, which I have to say is a little too basic, but I also don't really need to use it much.

CPU: AMD Ryzen 9 5900X · Cooler: Artic Liquid Freezer II 280 · Motherboard: MSI MEG X570 Unify · RAM: G.skill Ripjaws V 2x16GB 3600MHz CL16 (2Rx8) · Graphics Card: ASUS GeForce RTX 3060 Ti TUF Gaming · Boot Drive: 500GB WD Black SN750 M.2 NVMe SSD · Game Drive: 2TB Crucial MX500 SATA SSD · PSU: Corsair White RM850x 850W 80+ Gold · Case: Corsair 4000D Airflow · Monitor: MSI Optix MAG342CQR 34” UWQHD 3440x1440 144Hz · Keyboard: Corsair K100 RGB Optical-Mechanical Gaming Keyboard (OPX Switch) · Mouse: Corsair Ironclaw RGB Wireless Gaming Mouse

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×