Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

I have an AIO which is making weird noises

From videos i have watched i am assuming its air trapped inside of the pump, but usually it is from faulty mounting but i have it on the top and its new.

Link to post
Share on other sites

Its cooling good but its making weird noises like gurgling or what ever.

 

Link to post
Share on other sites

Where did you mount it? can you post a picture of inside the case?

mY sYsTeM iS Not pErfoRmInG aS gOOd As I sAW oN yOuTuBe. WhAt IS a GoOd FaN CuRVe??!!?

Link to post
Share on other sites

The pump should not be at the highest point in the system. If the radiator is front mounted make sure that at least a portion of it is higher up than the pump

Link to post
Share on other sites
44 minutes ago, Levent said:

Where did you mount it? can you post a picture of inside the case?

like this

 

on top

Link to post
Share on other sites
56 minutes ago, Tegneren said:

The pump should not be at the highest point in the system. If the radiator is front mounted make sure that at least a portion of it is higher up than the pump

That depends on a few factors, actually.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×