Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Okay, I have been having this issue since I build my PC for Christmas, here are the specs

Ryzen 5 3600

Aorus x470 gaming ultra (latest bios)

Corsair vengeance rgb pro 32gb (3200)

Corsair cx650w rgb 80+ psu

And of course, an rx 570 (upgrading when stock comes, I just want to enjoy gaming for the time being)

So my issue for the past few weeks has been the AMD driver constantly crashing, or as they say (timing out) I have tested RAM, the motherboard was just sent in for an RMA or whatever, my CPU was brand new off of Newegg, and the rx570 is one I've had since 2017, I have tried every fix I could find, I used DDU, reinstalled windows, etc... And nothing works, I'd assume I'd post this here since someone might have a brain, unlike reddit, thanks. ps, I have no idea where I posted this, I have never used this website before, thanks

IMG_20210122_115338899_HDR.jpg

IMG_20210122_131434850.jpg

Link to post
Share on other sites
2 minutes ago, Nate.t said:

his issue since I build my PC for Christmas, here are the specs

Ok, I can deconstruct the BSoD crash, if you can post the mini dump crash files here.

Are you OCing anything or running XMP? If so, turn that stuff off while we troubleshoot

So rise up, all ye lost ones, as one, we'll claw the clouds

Link to post
Share on other sites

-> Moved to Troubleshooting

^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×