Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

HELP! NEW SYSTEM

Earnist_
 Share

just built a new system with rx 470, download drivers for it but it says "no amd graphics driver is installed, or the amd driver is not functioning properly" their is also a message in device manager saying windows has stopped the device, how can I fix this

Link to comment
Share on other sites

Link to post
Share on other sites

Download DDU (Display Driver Uninstaller) and remove both Nvidia AND AMD drivers that you've overlapped. Then, install a fresh copy of the latest AMD drivers.

Link to comment
Share on other sites

Link to post
Share on other sites

16 minutes ago, 5x5 said:

Download DDU (Display Driver Uninstaller) and remove both Nvidia AND AMD drivers that you've overlapped. Then, install a fresh copy of the latest AMD drivers.

That didn't work it still says the same thing 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Earnist_ said:

That didn't work it still says the same thing 

Is the 470 used? You may have been scammed with a fake card.

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, 5x5 said:

Is the 470 used? You may have been scammed with a fake card.

Yes its used , its the strix model and not sure how to fix this

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Earnist_ said:

Yes its used , its the strix model and not sure how to fix this

You got scammed with a broken card or a fake card. Sorry :(

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×