Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

new computer won't post

I just bought a Ryzen 3600.  16gb of ram.  A ROG B450-f mother board.

 

When i  power up I get a red light and a yellow light.  I tried reseating the ram.

Link to comment
Share on other sites

Link to post
Share on other sites

I found this link with information in the comments on what it may be

Ryzen 5 3600

MSI B550 Tomahawk

16GB 3600mHz Trident Z RGB

1650 Super

Fractal Design Meshify C

Samsung 970 Evo 1TB

 

Link to comment
Share on other sites

Link to post
Share on other sites

37 minutes ago, coleman984 said:

I just bought a Ryzen 3600.  16gb of ram.  A ROG B450-f mother board.

 

When i  power up I get a red light and a yellow light.  I tried reseating the ram.

My guess is that maybe you need to update your BIOS for Ryzen 3rd gen support

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Dimondminer11 said:

My guess is that maybe you need to update your BIOS for Ryzen 3rd gen support

Yeah probably but I don't have any way of doing that.  I decided to rma the board and ordered a x570 for $20 less.

Link to comment
Share on other sites

Link to post
Share on other sites

8 hours ago, coleman984 said:

Yeah probably but I don't have any way of doing that.  I decided to rma the board and ordered a x570 for $20 less.

lol

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×