Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Random apps not working when connected to wifi works fine when connected via mobile data

Hey everyone i own a simple setup with a modem and a router 

Sometime ago after hearing about Cloudflare DNS and its features i decided to use their app in my phone and everything worked fine 

Now when i needed to use a separate vpn i googled how to make that dns default in the router and made it everything worked fine until one day i decided to watch some netflix in my Mobile phone and strangely it did not load

i own a MI A1 i tested in that device it did not work i checked it in other mobile devices too same issue occurred the other device was OnePlus 5t (both run android pie(stable) idk if this is relevant)  i went through the forums of these devices and noticed no such problems it is to be noted that i did not face any of these issues before i switched to the DNS of cloudflare in my router and modem and thinking that might be causing the issue i reset both my modem and router hoping that would solve the issue but nothing happend 

Anyone know what might be causing the issue

The apps i noticed to not work are

1}Netflix

2)Amazon Prime Music

3)PhonePE

IDK if there are more apps facing the same issue apps like prime video and youtube work just fine 

 

Please help in finding a solution 

 

I can attach any document necessary 

 

Please note i live in India so if you requested anything i might be asleep (blame TimeZones) i will surely give them when i am up

Thanks in advance 

Link to comment
Share on other sites

Link to post
Share on other sites

For Netflix at least, I've heard they have measures against VPN to block people accessing content that's not available in their own country.

PCPartPicker Part List: https://pcpartpicker.com/list/ZKsJvn

 

 

CPU: AMD Ryzen 7 3700X 3.6 GHz 8-Core Processor 
CPU Cooler: Cooler Master Hyper 212 LED Turbo (Red) 66.3 CFM CPU Cooler 
Motherboard: Gigabyte X570 AORUS ELITE ATX AM4 Motherboard 
Memory: G.Skill Ripjaws V Series 16 GB (2 x 8 GB) DDR4-3200 Memory 
Storage: ADATA XPG SX8200 Pro 1 TB M.2-2280 Solid State Drive 
Video Card: Asus Radeon RX 5700 XT 8 GB Video Card  
Case: Fractal Design Meshify C ATX Mid Tower Case 
Power Supply: SeaSonic PRIME Titanium 750 W 80+ Titanium Certified Fully Modular ATX Power Supply 
Operating System: Microsoft Windows 10 Home OEM 64-bit  
Monitor: Asus MG278Q 27.0" 2560x1440 144 Hz Monitor 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×