Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
dreamhacking

How to fix Ethernet Controller issue?

Recommended Posts

Posted · Original PosterOP

I had tried opening up the Device Manager, and at Other devices, I saw Ethernet Controller with a yellow triangle. 
I tried searching software on internet to update, no result found. 

I tried uninstalled it and scan for hardware change, and it still won't install properly. 

also tried installing the Bigfoot Lan driver, NO LUCK. 


It should be missing a driver, and I cannot connect to internet with Ethernet Cable. I need some help to figure out why.

This is a new build with Gigabyte H170 Gaming 3 mobo 

http://www.gigabyte.com/products/product-page.aspx?pid=5522#ov

 

Thank you 

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Pesukarhu said:

Download the bigfoot lan driver from that page you linked, install it, boom.
(it is in the support&downloads section, under drivers.)

That i have tried, Still won't connect to internet with Ethernet Cable, only wifi adapter is working. 

Link to post
Share on other sites
Posted · Original PosterOP
7 minutes ago, Pesukarhu said:

Try this, the mobo should have a killer lan chip in it.
http://www.killernetworking.com/driver-downloads/item/e2200-e2400-wireless

Thank you for the link. I will update again if it solves the problem. 

yes indeed on the mobo box it says Killer Ethernet ... lol 

that's why i am confused when the Bigfoot Lan driver is not working. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×