Jump to content
ProfessorMint

'The procedure entry point TerminateProcess could not be located

Recommended Posts

Posted · Original PosterOP

I'm not sure if this is 100% the right place so correct me if I'm wrong xD but this is a windows problem (I think).
For probably the past probably about half a year this has been happening, POSSIBLY after I upgraded to 10 and downgraded back to 7, but I'm not sure. It never really bothered me enough to try to figure it out until now. Every time I open certain files (Example; Arma 2 and 3 Launchers) there is an error that comes up saying this (picture in attachments)

Example:

A3Launcher.exe - Entry Point Not Found
The procedure entry point TerminateProcess could not be located in
the dynamic link library api-ms-win-core-processthreads-l1-1-1.dll


This doesn't affect anything I'm doing other than making me press OK every single time I open the file. Everything I use seems to work perfectly regardless of the error, but everything I've tried also hasn't made it go away. I'm not 100% confident in editing registry files without a full guide because of the amount of data on my PC (almost 2TB) that I don't really want to bother re-downloading. I've tried regsrv32'ing them (E.G. entering regsvr32 /u api-ms-win-core-processthreads-l1-1-1.dll) in an elevated CMD prompt, but it only shows this error (also attached, using /i produces the same error):

The module
"api-ms-win-core-processthreads-l1-1-1.dll" was
loaded but the entry-point DllUnregisterSerrver was not
found.

Make sure that
"api-ms-win-core-precoessthreads-l1-1-1.dll" is a valid
DLL or OCX file and then try again.


If anyone could explain what this is or how to fix it, that would be greatly appreciated ;)
 

Capture.jpg

Capture2.jpg

Link to post
Share on other sites

The program is trying to call a function in that dll but it's not where it expected (in terms of bytes from the start of the file) and it is failing as a result.

 

My best guess for a fix would be to get a different version (the right version) of that dll, but I can't offer any suggestions about which one that might be or where to find it.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.


×