Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Christicles

Speedfan at startup windows 8

Recommended Posts

Posted · Original PosterOP

Has anyone successfully gotten speedfan to run on startup in windows 8? I can't seem to get it to run and when I start it manually it takes a while for it to actually start. I have used task scheduler to start it, gave it full privileges  and even set the .exe to always run as admin, but it still won't run on startup.

 

Any suggestions?


AMD FX-4100(Temporary), MSI 990FXA-GD65, 8GB Dual-Channel DDR3, MSI 7950 Twin Frozr 3GD5/OC, MSI Radeon HD 5450, Asus Xonar DGX, M4 128GB SSD, 1TB Seagate Baracuda HDD, 250GB Hitachi HDD, CoolerMaster Silent Pro 700W PSU, CoolerMaster Storm Scout, Corsair H50

Link to post
Share on other sites

Usually motherboards have a bunch of utilities to chose from that can show you temp,fan speed,clock speeds...etc.Here is a link,take a look you may find a fan speed controller in one of these http://www.msi.com/product/mb/990FXA-GD65.html#/?div=Utility&os=Win8%2064 Try to download  MSI Control Center and see if it have what you want


Beware of him that is slow to anger; for when it is long coming, it is the stronger when it comes, and the longer kept. Abused patience turns to fury.
 
Link to post
Share on other sites
Posted · Original PosterOP

I was using speedfan fine before with Win 7.  It just seems to be having trouble in win 8 for some reason.


AMD FX-4100(Temporary), MSI 990FXA-GD65, 8GB Dual-Channel DDR3, MSI 7950 Twin Frozr 3GD5/OC, MSI Radeon HD 5450, Asus Xonar DGX, M4 128GB SSD, 1TB Seagate Baracuda HDD, 250GB Hitachi HDD, CoolerMaster Silent Pro 700W PSU, CoolerMaster Storm Scout, Corsair H50

Link to post
Share on other sites
Posted · Original PosterOP

Try this

http://www.eightforums.com/tutorials/5180-startup-items-manage-windows-8-a.html

Add Speedfan here (for Win 64-bit)

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run

 

Set speedfan.exe to always run as admin.

That seems to be it working, but it does seem to take a while to start. Like it is constantly scanning the hardware like the first time you start it up. Don't remember it taking so long in win 7 after running it the first time.


AMD FX-4100(Temporary), MSI 990FXA-GD65, 8GB Dual-Channel DDR3, MSI 7950 Twin Frozr 3GD5/OC, MSI Radeon HD 5450, Asus Xonar DGX, M4 128GB SSD, 1TB Seagate Baracuda HDD, 250GB Hitachi HDD, CoolerMaster Silent Pro 700W PSU, CoolerMaster Storm Scout, Corsair H50

Link to post
Share on other sites

Try this

http://www.eightforums.com/tutorials/5180-startup-items-manage-windows-8-a.html

Add Speedfan here (for Win 64-bit)

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run

 

Set speedfan.exe to always run as admin.

 

 

Actualy if had a bug before with another app i fixed it by un checking run as admin.

Apearntly this is something new.

 

Also do this tweak to kill the startup delay.

 

http://www.lifehacker.com.au/2013/02/kill-the-startup-delay-for-your-windows-8-desktop-apps/

Link to post
Share on other sites
Posted · Original PosterOP

Actualy if had a bug before with another app i fixed it by un checking run as admin.

Apearntly this is something new.

 

Also do this tweak to kill the startup delay.

 

http://www.lifehacker.com.au/2013/02/kill-the-startup-delay-for-your-windows-8-desktop-apps/

I tried the checking and unchecking thing before as well, but it didn't help.

Thanks for the speed tweak, need to try that out.


AMD FX-4100(Temporary), MSI 990FXA-GD65, 8GB Dual-Channel DDR3, MSI 7950 Twin Frozr 3GD5/OC, MSI Radeon HD 5450, Asus Xonar DGX, M4 128GB SSD, 1TB Seagate Baracuda HDD, 250GB Hitachi HDD, CoolerMaster Silent Pro 700W PSU, CoolerMaster Storm Scout, Corsair H50

Link to post
Share on other sites

Quote

I tried the checking and unchecking thing before as well, but it didn't help.

Thanks for the speed tweak, need to try that out.

Leave it un checked cous checking it prevents it from running, their a way to fix that but it breaks other stuff.

It kindy sux microsoft changed some stuff, which can cause lot trouble.

Link to post
Share on other sites

I had the same problem too. Windows 8 seem to be a bit iffy when it comes to adding software to the Startup folder, etc. I found a workaround, though. > http://letitknow.wordpress.com/2012/09/06/how-to-start-a-program-automatically-in-windows-8/

 

Scroll down to "Use task scheduler" and follow the guide and Speedfan should start with Windows. I haven't figured out how to make it start minimized yet, so you'll have to minimize it manually for now. It works and prevents my CPU from frying, so it's all good.  :lol:

 

*EDIT*: Completely forgot you can tick an option to make Speedfan start minimized. A bit tired today.  :P


/// POLICE ASSAULT IN PROGRESS ///

Link to post
Share on other sites

I have unchecked the "run as admin" option and Speedfan starts with system without any problems.

 

But if you want Speedfan to start minimized you have to:

- in Speedfan check start minimized options (Configure>Options>start minimized)

- make shortcut to speedfan.exe, right click on it, than properties, in shortcut tab set Run option to minimized

- add new string value for example Speedfan in (for Win 64-bit)

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run

and set the value of the string to path to the shortcut.



PS Don't use this method http://www.lifehacker.com.au/2013/02/kill-the-startup-delay-for-your-windows-8-desktop-apps/

My windows didn't start after that and I had to use windows recovery option.

Link to post
Share on other sites

I have unchecked the "run as admin" option and Speedfan starts with system without any problems.

 

But if you want Speedfan to start minimized you have to:

- in Speedfan check start minimized options (Configure>Options>start minimized)

- make shortcut to speedfan.exe, right click on it, than properties, in shortcut tab set Run option to minimized

- add new string value for example Speedfan in (for Win 64-bit)

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run

and set the value of the string to path to the shortcut.

PS Don't use this method http://www.lifehacker.com.au/2013/02/kill-the-startup-delay-for-your-windows-8-desktop-apps/

My windows didn't start after that and I had to use windows recovery option.

 

Yeah yeah, I've brought up an old threat. But the web is just one big archive, right?

 

I just joined up to say thank you for this, it solved the issues I had which were identical to the OP's. Great work.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×