Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Fabi20750

ASUS TUF Gaming B550-PLUS I/O Shield Problem

Recommended Posts

Posted · Original PosterOP

Hey Guys

 

Today I finally got my new B550 and I wanted to install it in an NZXT H510. I've installed the shield inside the case and tried to attach the mainboard. Unfortunately that didn't work. When I took a closer look to the I/O shield, I saw that there is a metal tab which looks a bit out of place. The other tabs can bend and the shield and the mainboard fit perfectly fine but the USB-C port tab doesn't seem to be "bendable".

 

I tried to bend it in any way but either it blocks the USB Port above or the space between the shield and the mainboard is not tight enough.

 

Has anyone here have the same board and can relate to that or did I do something wrong? Is it save to use a PC without an I/O shield?

 

Any help is appreciated.

IMG_0099.jpg

IMG_0100.jpg

IMG_0101.jpg

IMG_0102.jpg

IMG_0103.jpg

IMG_0104.jpg

IMG_0105.jpg

Link to post
Share on other sites
24 minutes ago, Fabi20750 said:

Hey Guys

 

Today I finally got my new B550 and I wanted to install it in an NZXT H510. I've installed the shield inside the case and tried to attach the mainboard. Unfortunately that didn't work. When I took a closer look to the I/O shield, I saw that there is a metal tab which looks a bit out of place. The other tabs can bend and the shield and the mainboard fit perfectly fine but the USB-C port tab doesn't seem to be "bendable".

 

I tried to bend it in any way but either it blocks the USB Port above or the space between the shield and the mainboard is not tight enough.

 

Has anyone here have the same board and can relate to that or did I do something wrong? Is it save to use a PC without an I/O shield?

 

Any help is appreciated.

 

<snipped>

Is there a small gap at the top of the Type-C port that the tab goes into...?

 

EDIT:

This implies there might be...

image.png.fab1000dafa875a3a2c1a50f71d0ef12.png


Did you test boot it, before you built in into the case?

WHY NOT...?!

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Eighjan said:

Is there a small gap at the top of the Type-C port that the tab goes into...?

 

EDIT:

This implies there might be...

image.png.fab1000dafa875a3a2c1a50f71d0ef12.png

It seems like there is a hole or a gap. Actually the tab on the shield is almost twice as big :(

IMG_0107.jpg

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×