Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ne0rmatrix

facebook not opening links in external browser

Recommended Posts

Posted · Original PosterOP

Ok i have an issue with my Samsung Galaxy A50. I have android 9 and facebook is opening some links in spotify. I see a news article and when i click on it expecting a web page instead i get the spotify app opening to its default home page in android. I mean the main page when u open app. I have facebook set to open links in external browser set, I have app integrations with games and stuff turned off. What is super annoying is the only way i have currently of stopping this is uninstalling spotify. I have not figured out how to stop this behavior by facebook. Oh and i have instant apps turned off too. I just want links to open in external browser for webpages and not randomly redirect to apps like spotify!

Link to post
Share on other sites

You have configured default apps on OS level. Look into settings. I don't know Samsung UI layout, so I can't guide further.


Skynet: MacBook Pro Late 2016 Space Gray | i7-6820HQ 2.7 GHz | 16 GB LPDDR3 | Radeon Pro 455 2048 MB | 512 GB NVMe SSD | 15" 2880x1800

HAL9000: Intel i5-9600k | Cryorig M9 | 16 GB Corsair Vengeance LPX DDR4 3200 MHz | Gigabyte Z390I AORUS PRO WIFI | MSI GTX 1080 Ti SeaHawk X | 1 TB Samsung 970 Evo Plus + 1 TB Crucial MX500 + 256 GB Samsung 850 Pro | Corsair TX650M | NZXT H210i | LG 34UM95 34" 3440x1440

Hydrogen server: Xeon E5-2675 v3 | Cooler Master Hyper 212X | 64 GB Kingston/Samsung DDR4 ECC | Asus Z10PA-D8 | Corsair HX1000 | 256 GB Samsung 850 Evo + 3x 3 TB WD Red + 2 TB Seagate | Fractal Design Define R5 | unRAID 6.7.0

Carbon server: Fujitsu PRIMERGY RX100 S7p | Xeon E3-1230 v2 | 16 GB DDR3 ECC | 60 GB Corsair SSD & 250 GB Samsung 850 Pro | Intel i340-T4 | ESXi 6.5.1

Big Mac cluster: 2x Raspberry Pi 2 Model B | 1x Raspberry Pi 3 Model B | 2x Raspberry Pi 3 Model B+

Link to post
Share on other sites
Posted · Original PosterOP

chrome is default web browser in settings and i have open in external web browser turned on. This issue is caused by instant article redirect inside facebook. I have not figured out how to disable instant articles the default answer is its a feature and you cannot disable it.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×