Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
tetraDROP

PC problems (input lag, degraded display and sound) due to EMI on signal cables or ground loop. Anyone able to offer advice?

Recommended Posts

Posted · Original PosterOP

I am hoping to get some advice here to track down a potential ground loop, or serious source of EMI/RFI (not sure if conducted or radiated). I figured there are some techie folks on here so maybe I can get some advice. I have a host of non destructive computer and peripherals related problems. The issue manifest as input lag (mouse, keyboard), degraded sound quality (muddied, and shallow sound), degraded wireless (throughout the house) and wired internet performance, screen artifacts (noise), and degraded display (hitching, tearing).

I have confirmed that it is not hardware related:

  • 4 different PC's (Windows 8.1, Windows 10, and 1 laptop (Windows 7)

  • 3 Monitors

  • Multiple Keyboards, Mice, Headphones, Speakers

  • Multiple Modems, Routers, and all new cables (shielded and non- shielded Ethernet and Display port cables do help slightly I believe.

Observations:

  • Using different circuits and configurations (power strips, or conditioners) around the house which changes the input delays and performance.

  • Moving cables away from each other helps even data cables are messing with each other.

  • Placing a phone on PC makes the mouse sensitivity feel two times as fast.

  • Placed ferrite cores and toroids onto data, and power cables changes mouse tracking, sound and display quality, and internet performance.

  • Different power strips, Gold and Platinum rated PSUs, a Furman power conditioner, and a Tripp Lite double conversion UPS. UPS does something makes the input latency better, and the power conditioner helped for a few days. The power conditioner helped the most with the sound and display issues.

  • Seems to be better at night but only slightly.

  • When an appliance in the home is switched on the amount of data latency, input lag and display issues amplifies.

  • Any setting in Windows or BIOS changes how the mouse preforms (power settings, and fans speeds do the most), however after some time it seems to degrade back to the same point.

  • Wifi in the home continually cuts out and some weird stuff like if my modem and router are one the same power strip the Wifi will not work. Desktop PCs connected to Wifi even two feet away from router makes the input latency lower however there is full one second stutters in games, browsers and video streams.

  • Used my PC at a friends house in another city and it works perfectly fine, night and day from my setup at home. I am actually shocked at how much deeper sound, colors and consistency of mouse tracking is compared to at my house.

I have had the power company out twice, and had two electricians check my grounding, neutrals, and outlets. All come clean. I poked around with an AM radio and while there are some sources of noise around the house, nothing stands out. My laptop on battery works better at random times yet still has the same issues.

 

Found several posts relating to the issue and it seems they all observe the same symptoms:

 

https://linustechtips.com/main/topic/1055893-power-issues-can-cause-input-latency-issues/

 

https://forums.blurbusters.com/viewtopic.php?f=10&t=3641

 

https://www.reddit.com/r/buildapc/comments/bafhfe/update_after_years_of_mouse_input_lag_and_other/

 

http://www.jonnyguru.com/forums/showthread.php?16546-Major-input-lag-caused-by-Power-issues-in-House

 

After reading several posts about this very issue and seeing first hand how ferrite cores, moving cables, and power conditioners etc affect it I have concluded that it is indeed an electrical noise issue in my home or from the power pole/utility. In the thread on r/buildapc some of the comments stated it is likely an issue with grounding. I am wondering if maybe an Isolation Transformer, or just lifting the ground would solve it.

If there is anyone that is knowledgeable in these areas of either breaking groundloops, or at least finding them, or dealing with finding sources of EMI and finding out what frequencies I need to filter please let me know. I understand any skepticism about what I have posted here as it seems absurd to me as well but it is the truth and I would love to know what the cause is and how it can affect digital devices in these ways. Thanks

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×