Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
vOidward

USB devices stop responding after repeated unplugs

Recommended Posts

Posted · Original PosterOP

Hey I'm having an issue that's isolated to my desktop but doesn't effect my surface pro 4. I bought a USB KVM style switch to quickly swap inputs between my PC and laptop. Issue is, after I swap back a few times, my keyboards stop responding on my desktop until I do a full reboot. I'm wondering if anyone has encountered an issue like this before. Plugging the devices into a different port still doesn't work - the keyboards simply stop responding on my desktop completely until I reboot.

 

So far I've tried:

  • Swapping inputs on the KVM (it's not the KVM, plugging and unplugging a keyboard alone in any USB ports has the same results)
  • Using different USB ports. Both USB 2 and 3 and the front panel USB 3's have this issue.
  • Disabling USB selective suspend.
  • Disabling "Allow the computer to turn off this device to save power" in the device manager for every device I could think relevant.
  • Enabling legacy USB support and diddling with every other USB related BIOS setting.
  • Uninstalling USB3 drivers and letting windows reinstall fresh ones.
  • Updating intel MOBO drivers.
  • Updating BIOS.

Any tips would be helpful.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×