Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
H.K.

Acer Predator G9-593 sata drive overheating and being dismounted by Intel Rapid Storage Technology but works just fine through SATA to USB adapter

Recommended Posts

Posted · Original PosterOP

Hi, I've been using my Predator 15 for about a year now. 
 

Spoiler

About a month ago my SATA drive was showing randomly occurring 10-20 seconds 100% usage and I couldn't find the cause. Launching Task Man, Explorer during that time would make them unresponsive. Media playing during that time, which are located on that drive would also make the media player unresponsive. After about a week of this, the drive started to be dismounted and a few days after that, even restarting the PC wouldn't mount the drive.
I swapped in an old drive and it was working fine for a few days, until today when it got overheated and was dismounted. The first drive that wouldn't mount back worked just fine when I connected it to a SATA to USB connector and wasn't as hot to the touch as it was when connected to the laptop's SATA connector.

 


Long story short, any drive connected to my laptop's SATA connector seems to be heating up beyond normal, causing random 100% usage for 10-20 sec, making things unresponsive.


I bought the laptop through newegg and had it shipped to My country. So sending it to the retailer isn't an option. I don't understand the problem, is it the SATA connector? Or is it something else? Could anyone help me out here?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×