Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
GBELILREESE

MICROSOFT BROKE MY MOUSE!!

Recommended Posts

Posted · Original PosterOP

As the title states what ever update was recent basically broke my mouse. After installing and restarting my computer the update messed with my mouse. 

 

The mouse works on my laptop. It keeps freezing when I try to move it then reverts back to normal then disconnects and repeats this process. 

Link to post
Share on other sites
3 minutes ago, GBELILREESE said:

The mouse works on my laptop

So your mouse is fine

 

You probably just need to reinstall drivers


Hi how are ya

Link to post
Share on other sites

Go to device manager, find the driver for your mouse, right click it and try updating first


Hi how are ya

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Slottr said:

Go to device manager, find the driver for your mouse, right click it and try updating first

I did this and I picked one of the drivers on my pc and now my mouse disappeared I'm using my phone to talk to you now. 

 

Ooooof

Link to post
Share on other sites
9 minutes ago, GBELILREESE said:

I did this and I picked one of the drivers on my pc and now my mouse disappeared I'm using my phone to talk to you now. 

 

Ooooof

Good try champ we'll get em next time

 

Just try to unplug and replug it in, windows should figure it out


Hi how are ya

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Slottr said:

Good try champ we'll get em next time

 

 

Just try to unplug and replug it in, windows should figure it out

Uhh I tried and it still ain't working I remember there was a way to revert back to a previous time in your pc I forgot how to do this tho

Link to post
Share on other sites
6 minutes ago, GBELILREESE said:

Uhh I tried and it still ain't working I remember there was a way to revert back to a previous time in your pc I forgot how to do this tho

Theres advanced startup in the settings menu or you can hold shift and restart


Hi how are ya

Link to post
Share on other sites
1 minute ago, GBELILREESE said:

Onn 

optical mouse 

model onnhm5374

Did you try restarting the computer?


|::::xxxxxx| 
|::::xxxxxx| 
|xxxxxxxxxx|
Link to post
Share on other sites
1 minute ago, GBELILREESE said:

Yes it was one of the first things I tried

Maybe try this, right click at the device in Device Manager and select Uninstall. Then right click anywhere and select Scan for hardware changes.


Making Internet a better place.

Link to post
Share on other sites

Mouse cursor is a common problem sometimes. Its really annoying. Might try reinstalling display drivers too. Its usually something to do with that for me when it happens.


|::::xxxxxx| 
|::::xxxxxx| 
|xxxxxxxxxx|
Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, PrinceNorris said:

Maybe try this, right click at the device in Device Manager and select Uninstall. Then right click anywhere and select Scan for hardware changes.

Ok I tried this and now my mouse has reappeared thank you. 

 

 

Link to post
Share on other sites
Posted · Original PosterOP

I factory reset my pc after I flopped the windows recovery and it still doesn't work I think it's probably my motherboard or something.

Link to post
Share on other sites

@GBELILREESE It may be a pure coincidence that it stopped working properly after an update. I would seek the problem physically. Clean the cable plug, and if you know how, tear down the mouse and check if there is not too much dust/junk and check the cable connector on mouse PCB.


Making Internet a better place.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×