Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

new PC no post - no power?

dgsddfgdfhgs
 Share

bought the new parts, no post, went to pc shop tested confirming mobo, ram, psu are fine. but friend did not get post when he got home

ryzen 2600 +old gtx750ti + new cx550m

can I just power on without ram or gpu, I only want to see it tries to turn on by spinning fans in psu

 

 

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, dgsddfgdfhgs said:

bought the new parts, no post, went to pc shop tested confirming mobo, ram, psu are fine. but friend did not get post when he got home

ryzen 2600 +old gtx750ti + new cx550m

can I just power on without ram or gpu, I only want to see it tries to turn on by spinning fans in psu

  

 

 

 

Memory / RAM / DRAM is required for the POST.

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Lordclouds said:

Memory / RAM / DRAM is required for the POST.

You can only see if the cpu works because of the led. Nothing else will work after that. You need at least one stick in order to get it to post

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Lordclouds said:

You can only see if the cpu works because of the led. Nothing else will work after that. You need at least one stick in order to get it to post

ok, so no gpu/ igpu is fine?

is that new safety measure to have at least 1 ram stick to trick psu to power on?

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, dgsddfgdfhgs said:

ok, so no gpu/ igpu is fine?

is that new safety measure to have at least 1 ram stick to trick psu to power on?

It's required by motherboards to have at least one ram slot occupied.

CPU:R9 3900x@4.5Ghz RAM:Vengeance Pro LPX @ 3200mhz MOBO:MSI Tomohawk B350 GPU:PNY GTX 1080 XLR8

DRIVES:500GB Samsung 970 Pro + Patriot Blast 480GB x2 + 12tb RAID10 NAS

MONITORS:Pixio PX329 32inch 1440p 165hz, LG 34UM68-p 1080p 75hz

 

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, dgsddfgdfhgs said:

ok, so no gpu/ igpu is fine?

is that new safety measure to have at least 1 ram stick to trick psu to power on?

you can power the psu on but it will not post if there is no ram.

Also if you don't have gpu how would you see if it posted

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Lordclouds said:

you can power the psu on but it will not post if there is no ram.

Also if you don't have gpu how would you see if it posted

You can hear the beep sound but that depends on the motherboard

Link to comment
Share on other sites

Link to post
Share on other sites

kind of stuck in a loop, I dont see psu fan spin, so that a bad sign.

but psu worked on another old pc. and may be bad ram comes next....

mobo has no speakers attached - asrock b450 itx

Link to comment
Share on other sites

Link to post
Share on other sites

17 minutes ago, Lordclouds said:

you can power the psu on but it will not post if there is no ram.

forgot to mention, I can see mouse led on when pc is off (never went on...)

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×