Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Networking Speed Issues

Recently when I've been going to download things I notice the speed bounces from 10Kbps-100Kbps. I know my computer and ISP in general are capable of 1Gbps, but I don't understand why it isn't utilizing that. Could it just be the host servers I download content from are old?

 

Specs:

Ryzen 7 1700

2x8GB DDR4 G.Skill Aegis

Gigabye AX370-Gaming 3-CF (internet via Cat5e cable)

MSI 1070 Gaming X 8GB

 

Link to comment
Share on other sites

Link to post
Share on other sites

If you're downloading from old/slow servers than you're going to be bottle necked by their infrastructure not yours. What happens when you try and download something off a new site like Steam/Battle.net ect? 

 

Have you done a speed test yet? http://www.speedtest.net/ to see at least a base of what your hardware and your ISP can deliver. 

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, Plumpo said:

If you're downloading from old/slow servers than you're going to be bottle necked by their infrastructure not yours. What happens when you try and download something off a new site like Steam/Battle.net ect? 

 

Have you done a speed test yet? http://www.speedtest.net/ to see at least a base of what your hardware and your ISP can deliver. 

I believe my ISP is limiting me. I am paying for 1Gbps and getting only 367Mbps Download. However the most recent items I downloaded are programs and games from 2002 so it's probably the host servers. Although I should still talk to my ISP about the other issues. Thanks.

Link to comment
Share on other sites

Link to post
Share on other sites

I pay for 1Gbps for mine through Spectrum, and i think I have gotten above 700Mbps once. Usually I'm sitting around 400-600mbs. I'm sure they have something in their agreements that you're getting speeds Up To 1Gbps and not a consistent service. I had Google Fiber about 2 years ago and that was up around 800 consistently. 

Link to comment
Share on other sites

Link to post
Share on other sites

You could try doing a speedtest.net test. If the performance is there then the slow download speeds is a server-side issue.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×