Jump to content

Legion Y520 stuttering.

Cecyl
 Share

My laptop started stuttering quite a bit recently, even while watching something I can hear the sound "popping" and the video micro-stuttering.

I managed to "fix" the issue by disabling Intel Turbo Boost with ThrottleStop. Figured I'd monitor whats going on with hwinfo..

So, my core 0 clock speed drops from ~3.6 to 0.8 for a split second with Intel boost enabled whereas without it, I get avg 2.7mhz with no drops, max temperature was 62C. There are no other differences in the log between my regular speed and the 0.8mhz I get. 

I don't want to use some 3rd party app to disable turbo everytime I use the laptop and I've got no idea what's the issue here.

Link to comment
Share on other sites

Link to post
Share on other sites

@Cecyl

When you see 0.8 GHz, open Limit Reasons and see if your CPU is BD PROCHOT throttling. This is a common problem. You will need to use ThrottleStop to disable BD PROCHOT on the main screen. Post lots of pics while your CPU is throttling if you need help.

 

Exit HWiNFO and turn on the ThrottleStop Log File option so you have a record of your CPU performance. Attach a log file to your next post. 

Link to comment
Share on other sites

Link to post
Share on other sites

@unclewebb 

https://pastebin.com/t7v5xxSQ Turbo

https://pastebin.com/781SdsY0 No turbo

The only thing I get in Limit Reasons is yellow "EDP other" under CORE and RING and its there all the time.

EDIT: Noticed that the clock speed drops depend on what I'm doing on.. 

For example: Playing Diablo 3 - I get no stutter/audio pops with or without turbo. Checked with HWinfo, clock speeds are roughly the same, youtube - clock speed drops to 2.5 - 2.7 and some audio pops. Same with netflix
Grim dawn: Clock speed drops to 0.8, stutters a LOT and its super noticable. Heh no idea whats up with that,.

 

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Cecyl said:

no idea whats up with that

Exit HWiNFO and post some ThrottleStop screenshots when throttling. 

 

Enable Speed Shift in the TPL window and clear the BD PROCHOT box on the main window. 

 

Lenovo used multiple different throttling methods over the years. These problems are usually easy to solve.

Link to comment
Share on other sites

Link to post
Share on other sites

You mean like this? I atteched SS of throttlestop with what you suggested. 

TS.PNG

TS2.PNG

Link to comment
Share on other sites

Link to post
Share on other sites

@Cecyl

What about a picture of the FIVR window? Quote me in your replies or I might not notice them. 

 

Enable the Log File option on the main screen and go play a game that used to throttle down to 0.8 GHz. Are you still having this problem? When finished testing, exit ThrottleStop so it can finalize the log file and attach your log to the next message you post. The log should be in your ThrottleStop / Logs folder.

 

Check the MMIO Lock box in the TPL window. 

Link to comment
Share on other sites

Link to post
Share on other sites

@unclewebb

 

Just to be clear, play the game with those options enabled? The logs I sent earlier from pastebin are exactly that but without those options.

EDIT: SS with MIMO lock.
 

FIVR.PNG

Link to comment
Share on other sites

Link to post
Share on other sites

@Cecyl

Check the High Performance box on the main ThrottleStop screen to switch to the Windows High Performance power plan.

 

Run a new log file with this change and the other changes I have mentioned. I need to see when your computer is running at 0.8 GHz. I did not see that in the previous log files you posted. 

 

In the FIVR window, set IccMax for both the core and the cache to the maximum, 255.75.

Link to comment
Share on other sites

Link to post
Share on other sites

@unclewebb

https://pastebin.com/GdiEG7pJ

Around 16:54 was when It started stuttering more. At First I thought they're gone but few minutes in, they started again.

EDIT: after playing for a while the stutters are way less common now with these settings

Link to comment
Share on other sites

Link to post
Share on other sites

@Cecyl

Your computer is still running poorly. 

 

Do you have any Lenovo power management software installed? Uninstall anything Lenovo related. 

 

On the main screen of ThrottleStop check the Speed Shift EPP box and where it says 128, click on that number and change it to 0.

 

Run another log file while gaming and post an updated set of ThrottleStop screenshots so I can make sure that everything is set correctly.

 

Does your battery still hold a charge? Some laptops have issues when the battery starts to go. 

Link to comment
Share on other sites

Link to post
Share on other sites

@unclewebb

 

16 hours ago, unclewebb said:

Do you have any Lenovo power management software installed? Uninstall anything Lenovo related. 

 

Nope, I reinstalled windows from fresh when I bought the laptop, that was years ago tho so shouldn't matter now.

 

 

16 hours ago, unclewebb said:

On the main screen of ThrottleStop check the Speed Shift EPP box and where it says 128, click on that number and change it to 0.

 

Run another log file while gaming and post an updated set of ThrottleStop screenshots so I can make sure that everything is set correctly.


Just to make it clear, all of the settings from before AND the 128 => 0, or just the latter?

 

 

16 hours ago, unclewebb said:

Does your battery still hold a charge? Some laptops have issues when the battery starts to go. 


The fact that you say that makes me think that might be the case. Nope, it doesn't. Lasts for maybe an hour of netflix. Any way to determine its the battery for sure? 
 

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Cecyl said:

All settings from before.

Your CPU is running fantastic in that log file. The CPU multiplier is mostly at 35 or slightly higher which is exactly where it should be running.

 

Are you still having any issues? When your computer is idle at the desktop, what does ThrottleStop report for C0% on the main screen? Some background processes will cause high idle C0%. This can interfere with smooth game play. My 4th Gen laptop is usually under 0.5% in the C0 state when my computer is idle. 

 

image.png.25323360aba23bd262946ad89b9cb148.png

 

Check the Task Manager Details tab for any rogue or useless tasks that do not need to be running 24/7. 

 

Your CPU is running at its max rated speed so any problems now are not likely to be CPU related. 

Link to comment
Share on other sites

Link to post
Share on other sites

@unclewebb

 

3 hours ago, unclewebb said:

Are you still having any issues? When your computer is idle at the desktop, what does ThrottleStop report for C0% on the main screen? Some background processes will cause high idle C0%. This can interfere with smooth game play. My 4th Gen laptop is usually under 0.5% in the C0 state when my computer is idle. 

Yeah, stutters are way more common with all those settings. C0 averages around i'd say 1.2%. (without the settings enabled)

The only process taking any "significant" memory is sometimes Antimalware service executable. Sometimes it goes up to 5% cpu and stays at around 200MB memory all the time.

So far the only thing that stopped the stutters was disabling turbo boost, not a single stutter when I do that.

Maybe I'll include a quick HWiNFO log? I may be just misinterpreting it.

HWiNFO Log - got a couple of stutters during this. No throttlestop.

If we don't figure this out. I might just disable turbo when I need to, and thanks in advance for all the effort 🙂

Link to comment
Share on other sites

Link to post
Share on other sites

@Cecyl

Turn off HWiNFO and run another ThrottleStop log with turbo boost enabled. In the Options window, check the Nvidia GPU box so Nvidia data is included in the log file. The CPU is running as it should be. It seems like the Nvidia GPU is being throttled. The log file should show if the GPU MHz and temperatures are steady or if there are regular drops in GPU MHz. 

 

Disabling turbo boost slows down the CPU and reduces power consumption. Your laptop might have a design issue where it is simply not capable of fully powering both the CPU and GPU when they are running at normal speed. My Lenovo Y510P has a similar issue where Lenovo decided to deliberately disable Intel turbo boost whenever the Nvidia GPU is active. Lenovo should be held accountable for these hidden tricks. If you are overclocking the Nvidia GPU then I would avoid doing that to conserve power.

 

Instead of using Disable Turbo to solve this problem, leave Intel turbo boost enabled and try lowering the Turbo Ratio Limits in the FIVR window. This allows you to control how much turbo boost the CPU uses. This might allow your computer to run smoothly without having to completely disable all turbo boost. 

 

What is the power rating of your power adapter? It seems like your laptop is starving for juice. 

 

Run the GPU-Z program and have a look for the GPU throttling temperature. Some laptop manufacturers released BIOS updates that significantly dropped the GPU throttling temperature. This can cause stutters due to extreme GPU throttling. 

Link to comment
Share on other sites

Link to post
Share on other sites

@unclewebb

 

https://pastebin.com/Lem6urrn - Here's the log with GPU included.

 

12 hours ago, unclewebb said:

What is the power rating of your power adapter? It seems like your laptop is starving for juice. 

 

Its the adapter that i've got with the laptop, 100-240V~2.5 50-60mhz input, 20V 6,75A output.
 

 

12 hours ago, unclewebb said:

Run the GPU-Z program and have a look for the GPU throttling temperature. Some laptop manufacturers released BIOS updates that significantly dropped the GPU throttling temperature. This can cause stutters due to extreme GPU throttling. 

Where do I find that info?

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, Cecyl said:

Here's the log

The log shows both the CPU and GPU happily running at full speed. The Nvidia GPU is only at 60°C so it has no reason to be throttling. Were you experiencing stuttering during this time when you were logging this data? Are you running Discord? Your stutter issues might be related to a background process running on your computer. Try temporarily disabling a few things like Discord. Look at the Task Manager Details tab to find processes that you do not need. Get your idle C0% as low as possible. Exit HWiNFO while testing. 

 

20 hours ago, Cecyl said:

the only thing that stopped the stutters was disabling turbo boost

Did you try reducing the turbo ratio limits a little instead of disabling turbo boost? This might allow you to run some turbo boost without having to completely disable it. Start by setting all of the turbo ratios equally to 34, do some testing, and then reduce the turbo ratios further and test again. It does not make too much sense that turbo boost is causing the stutters you are experiencing. If that is what you are experiencing then I guess you will have to play games with turbo boost disabled. 

 

5 hours ago, Cecyl said:

Where do I find that info?

The GPU throttling temperature is usually listed in one of the GPU-Z tabs. This information might not be reported for your GPU. Your Nvidia GPU temperatures are nice and low so I would not worry about this. 

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, unclewebb said:

The log shows both the CPU and GPU happily running at full speed. The Nvidia GPU is only at 60°C so it has no reason to be throttling. Were you experiencing stuttering during this time when you were logging this data? Are you running Discord? Your stutter issues might be related to a background process running on your computer. Try temporarily disabling a few things like Discord. Look at the Task Manager Details tab to find processes that you do not need. Get your idle C0% as low as possible. Exit HWiNFO while testing. 

The first thing I did was monitor my task manager usages, nothing goes up when the stutter happens and yes, it was still happening during that log.

I've got 72 processes in background (of which like 15 are nvidia and steam) and 92 windows ones. Is that a lot?

 

 

3 hours ago, unclewebb said:

Did you try reducing the turbo ratio limits a little instead of disabling turbo boost? This might allow you to run some turbo boost without having to completely disable it. Start by setting all of the turbo ratios equally to 34, do some testing, and then reduce the turbo ratios further and test again. It does not make too much sense that turbo boost is causing the stutters you are experiencing. If that is what you are experiencing then I guess you will have to play games with turbo boost disabled. 


So far this helps, reduced it to 34 and stutters seem to be gone. Do I need to reopen ThrottleStop everytime I boot my laptop?


Btw, I recorded and uploaded a clip when the stutters happen as a last resort, maybe that'll help figure it out? 

Here's the clip, it's most noticable at 0:36. Its way more noticable live compared to recording.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×