Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

OMV newbie, just playing around but stuck for two nights.

Bitter
 Share

So I'm just playing around with OMV because it looked easy to use and it has been so far but I'm snagged. I did the things, I can see it on the network from Windows, can see the shared folder I made, but when I try to access it I get the fan favorite "Windows cannot access \\OMV\Test1 You do not have permission to access \\OMV\Test1, contact your admin". Well I talked to myself and I'm not clear what's going on. I made some users, I gave them permissions, I've tried guests allowed, guests only, and No. For my own internal 'messin around' purposes security is not a concern right now, I'd just like to get it up and working so I can play with it more fully and figure out if this is something I want to pursue further or not.

 

I'm sure I'm missing something very simple, Googlin has sent me off on some pretty wild seeming tangents like registry editing, etc which seem a bit off the deep end. I haven't messed with Samba shares since Windows XP and early Windows 7 days a long time ago so I'm really rusty with these things. I need a little ELI5 hand holding, I'm a hardware guy.

 

EDIT: Just tried from my Ubuntu laptop and I'm able to access it when I login with user credentials from one of the users I set up. I don't get a login prompt in Windows unless I set it to No in which case the username and password that SHOULD login do not login. Seems to be a Windows problem not an OMV configuration issue?

Link to comment
Share on other sites

Link to post
Share on other sites

You need to add a user to the share in omv, then add the matching credential in windows credential manager. Its the only way ive found that works reliably. Guest access to smb shares is turned off by default in windows iirc.

Link to comment
Share on other sites

Link to post
Share on other sites

6 hours ago, markr54632 said:

You need to add a user to the share in omv, then add the matching credential in windows credential manager. Its the only way ive found that works reliably. Guest access to smb shares is turned off by default in windows iirc.

I'm fairly sure I tried that but I'll try again tonight and detail the steps I took here so maybe you can spot my foul up. I'm bumping into the issue that a lot of the better videos and how to guides are for previous versions and things are different enough that I'm not sure I'm hitting all the steps.

Link to comment
Share on other sites

Link to post
Share on other sites

45 minutes ago, markr54632 said:

https://docs.microsoft.com/en-us/troubleshoot/windows-server/networking/guest-access-in-smb2-is-disabled-by-default

 

This gives the registry value to enable smb guest access.

 

Im not super happy with the way my omv shares interact with windows. Works great with android and linux though.

 

I'll give that a whirl too, when I ran across that I was like 'woah ok I don't remember this' and came here for advice.

What don't you like? Ages ago I ran a samba share with XP and 7 and it was a fairly smooth experience having it just as a network shared drive but I guess that's all out the window these days.

Link to comment
Share on other sites

Link to post
Share on other sites

I had similar issues setting up acess to the shares to what you are describing. Any time i set a new machine or vm up i need to make new credentials instead of just logging in. Works seemless with linux though.

Link to comment
Share on other sites

Link to post
Share on other sites

No time tonight, I'll get to it though.

So are these just Win10 and Samba problems in general or OMV specific?

Link to comment
Share on other sites

Link to post
Share on other sites

On 6/29/2022 at 12:35 PM, markr54632 said:

https://docs.microsoft.com/en-us/troubleshoot/windows-server/networking/guest-access-in-smb2-is-disabled-by-default

 

This gives the registry value to enable smb guest access.

 

Im not super happy with the way my omv shares interact with windows. Works great with android and linux though.

 

Editing the group policy got it! Thank you! I can easily repeat this on the other Windows PC's now!

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×