Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Terrible Gigabyte support

So i bought a 3080 aorus master back when you couldn't get them. I got it and i was having random black screens, i tried a bunch of stuff and it didn't fix anything. Talked to Gigabyte support and when through their steps to trouble shoot and sent it back in for an RMA. When I received it back and it said it was repaired, i was like sweet finally get to enjoy my card after the 3 week RMA process where i had to pay to ship it to them. Put it in and get things going and boom same thing, it's very random when it happens. So i, assuming they fixed it i bought around ~$1000 of trouble shooting hardware to eliminate anything that could be the problem. Intel, amd, ram, ssd, hdd, different os, powersupplies, etc. Literally every part and it still does the same thing. I check my temps and i didn't notice this before they they are really high, and i even had the side panel off and the room temp was ~70.(picture attached) After creating a new ticket they said i should use it and i need to send it back in. So i asked why wasn't this checked when you fixed it? and here is where i find out they didn't fix it becasue they couldn't duplicate it in a 12hour test. I'm like WTF dont put "repaired" when its "CND" (can not duplicate). So at this point im pretty pissed, i've wasted a bunch of money on hardware i don't need and i'm going to have to pay to ship it back and wait 3 weeks again. I've called 3 times and the customer service manager to try to get a refund of the purchase price or at least current market value at minimum and he was apparently not available all three times, this is all over the course of 3 days. I don't want this POS from this company, i will never be buying from them again. The lower person on the phone tried to tell me that the temps are normal and i was like why did support tell me not to use it and RMA it again.

 

Has anyone else had any luck with gigabyte support? 

gputemp1.PNG

Link to comment
Share on other sites

Link to post
Share on other sites

Luckily my two times dealing with the gigabyte support went buttery smooth. But I've heard that people having bad experiences with them quite a few times now 😞

Link to comment
Share on other sites

Link to post
Share on other sites

With the side panel on it clocks down to ~1450mhz. This is after it's been "repaired" and stress tested. 106c on the mem and 104c on the hotspot. I figure if they won't give me the money back im going to burn it to the ground so they can't fix it so i can get a new one. Then i will be selling it and buying an Evga card.

Link to comment
Share on other sites

Link to post
Share on other sites

I wouldn't be surprised if you would open the card and find out there are no thermal pads or thermal paste.

I know Sir Carrey Holzman had issues with their support regarding MoBos so he avoided them.

If you can not return the card anymore I'd open the cooler and see what is under it.

 

 

Please do not take offence for my apparent confusion or rudeness,it's not intent me to be like that,it's just my BPD,be nice to me,and I'll return twice better,be rude and usually I get easly pissed of...I'll try to help anyone here,as long as it's something I dealt with,and even if you think I'm rude or not polite,forgive me,  it's not me it's my BPD.

Thanks for understanding.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×