Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

fix

No fix needed. It's just throwing a note that you need to use 3 seperate cables from the PSU for the GPU, not the daisy-chain ones many PSUs include. 

Intel HEDT and Server platform enthusiasts: Intel HEDT Xeon/i7 Megathread 

 

Current Rig

Spoiler

i7 6950X - EVGA X99 Classified - 4x8GB 3200Mhz CL16 DDR4 - 2060 Super FE - 1TB 970 Evo + 1TB MX500 - LG WH14NS40 BluRay Drive - EVGA 1000W G3 - Corsair Air 540 - Noctua iPPC NF-A14 3000 (rear) + 3x Noctua NF-P12 redux-1700 PWM (radiator) - LG 27UK650-W (27" 4K60hz) - Custom CPU/GPU Loop w/single 360mm rad - Windows 10

Project Rig (WIP)

Spoiler

Xeon I forgot the name of - NH-L12S - EVGA X99 Micro 2 - 4x4GB 2800MHz DDR4 - WX2100 2GB - 256GB 960 Evo - Flex-ATX PSU - Old Dell OEM case - Noctua 80mm fans - probably will be Windows or Ubuntu

 

Daily Devices: 2015 15" MacBook Pro (Work Laptop) - iPhone 13 Pro Max - Apple Watch Series 3 (if I don't forget to put it on) || Other Misc Devices: iPod Classic 5th Gen 30GB- iPod Classic 7th Gen 80GB - Nintendo Switch - Switch Lite - Wii U

Link to comment
Share on other sites

Link to post
Share on other sites

That monster of a PSU is plenty compatible... don't worry... Its just a warning to alert you that there are 3x 8pin's for that GPU, you will be fine.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×