Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Gtx 660 Multiple Display Issue

112c
 Share

So I’ve had this gtx 660 and I tried using it would work if I only used one monitor but as soon as I plug in any other display into a port the screen goes black all usb is gone but I can connect via ssh or ping it on the network. I’ve tried both windows and Linux 

cooking oil isn’t a alternative for tanning oil

Link to comment
Share on other sites

Link to post
Share on other sites

it's either a hardware (gpu is bad/has dud port etc) or a driver issue

Link to comment
Share on other sites

Link to post
Share on other sites

It could be but it’s weird because it’s only when there’s more than 1 Monitors because the gpu has 4 outputs 2 dvi 1 hdmi and 1 display port and I’ve used all of them and if I use any more than one of the ports the screen goes black and the pc hangs

cooking oil isn’t a alternative for tanning oil

Link to comment
Share on other sites

Link to post
Share on other sites

13 minutes ago, 112c said:

It could be but it’s weird because it’s only when there’s more than 1 Monitors because the gpu has 4 outputs 2 dvi 1 hdmi and 1 display port and I’ve used all of them and if I use any more than one of the ports the screen goes black and the pc hangs

GPU Model ?
What outputs you tried it with ?

There is approximately 99% chance I edited my post

Refresh before you reply

__________________________________________

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×