Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Streaming problems

qvtran
 Share

Hi I've been recently trying streaming on twitch. I have a PC with really great specs and my internet has 25 upload speed. But for some reason my PC can't handle streaming even on 720p60fps.

Can please someone give me some advice? Thank you in advance. 🙂

 

Link to comment
Share on other sites

Link to post
Share on other sites

I'm not a streamer, but for people to be able to help you should provide more information such as your full PC specs and streaming setup, streaming bitrate, settings etc.

Crystal: CPU: i7 7700K | Motherboard: Asus ROG Strix Z270F | RAM: GSkill 16 GB@3200MHz | GPU: Nvidia GTX 1080 Ti FE | Case: Corsair Crystal 570X (black) | Storage: 250 GB Crucial BX100 SSD + 2 TB Seagate HDD + 1TB WD Green + 3TB WD Red | PSU: EVGA Supernova G2 1000W | Monitor: Asus VG248QE 24"

Laptop: Dell XPS 13 9370 | CPU: i5 10510U | RAM: 16 GB

Link to comment
Share on other sites

Link to post
Share on other sites

-> Moved to Programs, Apps and Websites

***

 

Saying "great specs" and then saying "PC can't handle" means that your specs aren't so great that you can play whatever you play and encode it at the same time. Or you have wrong encoder set up. Either way, without full details, you don't be getting any detailed help either.

^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to comment
Share on other sites

Link to post
Share on other sites

On 12/5/2021 at 11:12 PM, LogicalDrm said:

-> Moved to Programs, Apps and Websites

***

 

Saying "great specs" and then saying "PC can't handle" means that your specs aren't so great that you can play whatever you play and encode it at the same time. Or you have wrong encoder set up. Either way, without full details, you don't be getting any detailed help either.

Hello,
these are my PC specs
CPU: 5900x
GPU: 3080
RAM: 32GB 3200mhz

 

Streaming settings are:
res: 1280x720 60fps
Bitrate: 4500 

Thanks for your answer, I appreciate it 🙂

 

Link to comment
Share on other sites

Link to post
Share on other sites

14 minutes ago, qvtran said:

Hello,
these are my PC specs
CPU: 5900x
GPU: 3080
RAM: 32GB 3200mhz

 

Streaming settings are:
res: 1280x720 60fps
Bitrate: 4500 

Thanks for your answer, I appreciate it 🙂

 

And the encoder? Do you have same issues with recording? And what kind of issues they are? Frame drops? High CPU/GPU usage? Pixelation on stream? Buffering?

^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, LogicalDrm said:

And the encoder? Do you have same issues with recording? And what kind of issues they are? Frame drops? High CPU/GPU usage? Pixelation on stream? Buffering?

Hi!

I'm using Nvenc new, recordings are sometimes laggy and when I stream the video is laggy and I get frame drops. 😕

unknown.png

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, qvtran said:

Hi!

I'm using Nvenc new, recordings are sometimes laggy and when I stream the video is laggy and I get frame drops. 😕

unknown.png

Have you tried with different driver for GPU? Is the GPU working otherwise fine, getting at 80%+ usage and temps are fine? Have you tried if things are better with CPU encoding?

^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to comment
Share on other sites

Link to post
Share on other sites

31 minutes ago, LogicalDrm said:

Have you tried with different driver for GPU? Is the GPU working otherwise fine, getting at 80%+ usage and temps are fine? Have you tried if things are better with CPU encoding?

How do I try different drivers? I do not think the gpu got over 80% workload, I got 70 degree celsius constantly. I have not tried CPU encoding, it is the X264 right? I will give it a try. 
Thank you for being in touch with me. 🙂

 

Link to comment
Share on other sites

Link to post
Share on other sites

7 minutes ago, qvtran said:

How do I try different drivers?

Check your current driver version, then download either version or two older, or beta driver and install that one. Or if you aren't on newest driver, try with that first.

 

7 minutes ago, qvtran said:

I do not think the gpu got over 80% workload,

This would mean its not utilized fully. GPU should be over 60%, preferably over 80% when gaming.

 

And yeah, x256 is CPU encoding. You should be good on either, and this feels like driver issue since its happening on both recording and streaming.

^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, LogicalDrm said:

Check your current driver version, then download either version or two older, or beta driver and install that one. Or if you aren't on newest driver, try with that first.

 

This would mean its not utilized fully. GPU should be over 60%, preferably over 80% when gaming.

 

And yeah, x256 is CPU encoding. You should be good on either, and this feels like driver issue since its happening on both recording and streaming.

Hey,
it seems I will end up using x264, it can stream 1080p60fps without any issues, while nvenc new could not even stream 720p30fps 😄
Do you have any clue why nvenc has these issues?
Thank you for your assitence by the way 🙂 

Link to comment
Share on other sites

Link to post
Share on other sites

10 hours ago, qvtran said:

Hey,
it seems I will end up using x264, it can stream 1080p60fps without any issues, while nvenc new could not even stream 720p30fps 😄
Do you have any clue why nvenc has these issues?
Thank you for your assitence by the way 🙂 

Like I said, drivers. Could be one version with issues, but could be more serious issues with GPU as whole. Hard to say, but I think we've pinpointed where the issue is.

^^^^ That's my post ^^^^
<-- This is me --- That's your scrollbar -->
vvvv Who's there? vvvv

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×