Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Drivers Installation troubleshooting

Dandohyung1214
 Share

I was setting up my pc and downloaded the drivers and tried to install it. I restarted the px as per instruction of the installation soft ware and now the pc only shows this 

IMG20211127155730.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

Inaccessible boot device is BAAAAAD. What driver were you installing? I'd guess something related to your HDD/SSD obviously.. If you have access to another PC and a USB stick, I'd start prepping it as a Windows recovery drive. Using the recovery tool, you'll be able to try and repair Windows or fresh install at the worst.

System Specs: (Click Expand)                                                       Please use quote when replying so I get a notification.

          "Beatrix"

  • CPU AMD Ryzen 7 3700X
  • Motherboard GIGABYTE X570 I AORUS Pro Wi-Fi
  • RAM 2 x 16GB Corsair Vengeance RGB Pro @ 3200mhz CL16
  • GPU EVGA Geforce GTX 1080 SC
  • Case Corsair Crystal 280x
  • Storage 1x Samsung 980 Pro (1TB) 1x Samsung 970 Evo Plus (500GB) 1x Samsung 860 Evo (1TB)
  • PSU EVGA 850 GQ
  • Display(s) 27" Viewsonic XG2705
  • Cooling Corsair H100i Elite Capellix AIO | 4x QL120 RGB fans | 2x QL140 RGB fans
  • Keyboard Logitech G213
  • Mouse Logitech G502 Lightspeed /w Powerplay
  • Sound Corsair HS60 Pro
  • Operating System Windows 10 Professional 21H1
Link to comment
Share on other sites

Link to post
Share on other sites

I was installing my chipset drivers and some mobo drivers and then clicked on restart as per instruction. What do i do?

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×