Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Display Port not showing BIOS with GTX 1080

I recently got a used GTX 1080 Gigabyte OC edition and I noticed that when working with display port, my monitor doesn't pick up any signal on startup. On the other hand, hdmi works flawlessly. So I have to start up my pc with hdmi plugged in and then switch the cables manually for DP to work properly. This however wasn't the case with my old GTX 1060, so what is the problem here?

 

GPU: GTX 1080 Gigabyte OC

Monitor: AOC 24G2

Motherboard: Asus H370-A prime

OS: Windows 10 Education

Link to post
Share on other sites

Different MFG for the GPU's?  GPU firmware need updates?

Link to post
Share on other sites
F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX3080, 2TB SX8200Pro, 2x16TB Ironwolf RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary, Mountain Everest Max

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB SX8200Pro RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K

 

GPD Win 2

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×