Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Prevent performance loss on Server when RDP is disconnected

I'm having a weird use-case (don't ask) in which I am running a Game on a remote Windows Server 2019 host.

 

When I am connected over RDP it runs and performs fine, but as soon as I minimize the RDP Window or close the RDP connection, the Game suffers a huge performance hit and runs choppy.

 

The hosts power plan is set to High Performance, Sleep and Idling is set to Never occur, but I can't find a way to circumvent the performance hit when no remote display is connected.

 

Is there a way to prevent the host from throttling performance while no virtual display is connected? 

 

EDIT:

The performance loss seems to be caused by the game, rather than the Windows Server. I tried settings priority to realtime and other tweaks within Windows, but nothing helped. The game itself doesn't have a "power saving mode" that I could disable. When I disconnect the RDP, it considers the game as minimized and therefore the game throttles performance while minimized.

Link to post
Share on other sites

Physically plugging a dummy display plug to the GPU should help in this situation.

F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX3080, 2TB SX8200Pro, 2x16TB Ironwolf RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary, Mountain Everest Max

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB SX8200Pro RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K

 

GPD Win 2

Link to post
Share on other sites

That would work, but I don't have physical access to the machine.

 

If there is a solution, it would have to be software.

Link to post
Share on other sites

Don't think that exists...

F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX3080, 2TB SX8200Pro, 2x16TB Ironwolf RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary, Mountain Everest Max

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB SX8200Pro RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K

 

GPD Win 2

Link to post
Share on other sites

Thanks for the input.

 

It was due to the software, nothing a windows setting could have done.

 

A workaround was to have a Android Smartphone connected to the host to keep the performance.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×