Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Some programs are causing my mouse to lag

Here are my specs:

 

AMD 5950X

RTX 3090

PCI-E Gen 4 Western Digital NVME

X570 Meg Ace Motherboard

64GB RAM OC'ed to 3800 MHz

 

I didn't have this problem before, but certain programs like Playnite game launcher, Photoshop, AMD Ryzen Master causes my mouse to lag/skip. It's like the mouse is skipping frames or something. When I minimize the offending app, this problem immediately ceases.

 

I can't for the life of me figure out the similarities of these specific programs to reproduce the problem. I first thought it's my GPU, but it games just fine, video edits like a champ, and run other 2D apps without a hitch.

 

Any ideas?

Link to post
Share on other sites

I've heard that some UEFI settings on Ryzen 5000 can affect system responsiveness, which would likely manifest as mouse lag. I'd try playing around with PBO and AutoOC. Maybe get AMD's new auto tunning software and try running that.

Link to post
Share on other sites
11 hours ago, AaronThomas said:

I've heard that some UEFI settings on Ryzen 5000 can affect system responsiveness, which would likely manifest as mouse lag. I'd try playing around with PBO and AutoOC. Maybe get AMD's new auto tunning software and try running that.

I'll check this out. Thanks for the tip!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×