Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can't get my 5000 series to work

Hey everyone!
 

I just upgraded to AMD 5800x and my cousin was helping with with rebuilding ym PC. He updated the bios on my Auros B450 Elite V2 motherboard but whenever we try to run the PC, it just does not want to work with us. I also have a new m.2 that I need installed but when it is inserted it doesn't let me boot into windows. I'm tried of trying to tinker with it. Any ideas on what I could be missing?

Link to post
Share on other sites

I need more details.

 

Does your machine boot into BIOS? Or it will not start at all?

Does it load up your OS but it can not finishing loading? (Spin thing goes forever)

If the top two does not describe “not want to work", tell me what went on after you press the power button, are lights on if there is any, does fan spin, etc.

Link to post
Share on other sites

So according to what my cousin just told me, he tried updating the bios but I guess it didn't want to update


I have my old 1700x CPU currently in the PC and it boots up fine, but apparently we can't get the bios to update so I think that's where I need to start.

Link to post
Share on other sites

Try different BIOS versions, make sure you give it time to fully update. I circled the ones you need to use, make sure you read the readme since you sometimes need to rename it or click something and put it someplace specific.

https://www.gigabyte.com/us/Motherboard/B450-AORUS-Elite-V2-rev-1x/support#support-dl
image.png.8836853fca914d45cfe29f48cbad9b60.png

CPU: Ryzen 5600x | GPU: Heckin' 1080 @2.0GHz | Mobo: Asus x570 TUF | RAM: 32GB CL16 3200 | PSU: EVGA 750G+ | Case: Corsair 450D | Storage: Several | Cooling: Brown | Thermal Paste: Yes

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×