Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Pls help i get microstutters in every games

Hello,

 

I am experiencing stuttering / frame time spikes in every game I play. I have spent weeks trying to diagnose what could be causing them but to no sucess. I bought this PC 4 or 5 months ago everything was fine but  these past few weeks frames spikes or microstutters occured ruining my gaming experience. At first i thought i could just ignore it but now its really getting on my nerves. its my first gaming pc ever so PLS HELP ME.

 

 

MY SPECS:

 

 

CPU:  Intel Core i5-9400F 6-Core 2.9 GHz

GPU:  GIGABYTE GeForce GTX 1660 Super OC 6G

RAM:  Team T-FORCE Vulcan Z 3200MHz (max speed) 16GB (2X8GB)

STORAGE:  512GB Intel 660p M.2 SSD

CASE:  NZXT H510

MOTHERBOARD:  ASRock B365 Phantom Gaming 4

CPU COOLER:  DEEPCOOL GAMMAX GTE V2

POWER:  EVGA 500W BR Bronze

WIFI MSI AX905C WIFI

 

 

 

EXEMPLES OF MY STUTTERING (Timestamps are in the videos descriptions)

 

EXEMPLE 2 

 

EXEMPLE 3

 

EXEMPLE 4

 

 

the stuttering occurs every minute i tried everything and now im deseperate, thx for reading (Sorry for bad english)

 

 

 

Link to post
Share on other sites

coffee lake i5 cpus and many other non hyperthreaded chips suffer from microstutter in a lot of games, especially the locked, low speed ones like the 9400. this is compounded by your ram not being able to run at full speed, a b365 motherboard limits you to 2666mhz instead of 3200mhz. i'm not aware of anything you can do to alleviate this stuttering with your current hardware, maybe someone else here has good ideas

topics i need help on:

Spoiler

 

 

my "oops i bought intel right before zen 3 releases" build

CPU: Ryzen 5 3600 (placeholder)

GPU: Gigabyte 980ti Xtreme (also placeholder), deshroud w/ generic 1200rpm 120mm fans x2, stock bios 130% power, no voltage offset: +70 core +400 mem 

Memory: 2x16gb GSkill Trident Z RGB 3600C16, 14-15-30-288@1.45v

Motherboard: Asus ROG Strix X570-E Gaming

Cooler: Noctua NH-D15S w/ white chromax bling
OS Drive: Samsung PM981 1tb (OEM 970 Evo)

Storage Drive: XPG SX8200 Pro 2tb

Backup Storage: Seagate Barracuda Compute 4TB

PSU: Seasonic Prime Ultra Titanium 750W w/ black/white Cablemod extensions
Case: Fractal Design Meshify C Dark (to be replaced with a good case shortly)

basically everything was bought used off of reddit or here, only new component was the case. absolutely nutty deals for some of these parts, ill have to tally it all up once it's "done" :D 

Link to post
Share on other sites

Well I can see there that your CPU usage is on par or higher than your GPU usage, which is usually bad. 

Can you show utilization for each core as well as vram and dram usage? Also Temps would be nice to see. 

 

For now I'd say try to close all background programs and see if that helps. 

Gaming HTPC:

R7 1700X - Scythe Big Shuriken 3 - Asus ROG B350-i - Asus GTX 1080 Strix - 16gb G.Skill Ripjaws V 3333mhz - Silverstone SX500-LG - 500gb 960 EVO - Fractal Design Node 202 - Samsung 60KS7090 - Logitech G502 - Thrustmaster T500RS - Noblechairs Icon


Desktop PC:
R9 3900X - H100i GTX - Asus Prime X570 Pro - EVGA RTX2060KO - 32gb LPX 3200mhz - EVGA 750G2 - 250gb 970 Evo - 6TB WD My Book Duo (Reds) - Inwin 103 White - Dell U3415W - Qpad MK-85 Brown - Logitech MX518 Legendary - Blue Yeti Platinum - Noblechairs Icon 


Boss-NAS [Build Log]:
R5 2400G - Noctua NH-D14 - Asus Prime X370-Pro - 16gb G.Skill Aegis 3000mhz - Seasonic Focus Platinum 550W - Fractal Design R5 - 
250gb 970 Evo (OS) - 2x500gb 860 Evo (Raid0) - 6x4TB WD Red (RaidZ2)

 

Audio Gear:

Hifiman HE-400i - Kennerton Magister - Beyerdynamic DT880 250Ohm - AKG K7XX - Fostex TH-X00 - O2 Amp/DAC Combo - 
Klipsch RP280F - Klipsch RP160M - Klipsch RP440C - Yamaha RX-V479

 

Reviews and Stuff:

GTX 780 DCU2 // 8600GTS // Hifiman HE-400i // Kennerton Magister
Folding all the Proteins! // Boincerino

Useful Links:
Do you need an AMP/DAC? // Recommended Audio Gear // PSU Tier List 

Link to post
Share on other sites
14 hours ago, FloRolf said:

Well I can see there that your CPU usage is on par or higher than your GPU usage, which is usually bad. 

Can you show utilization for each core as well as vram and dram usage? Also Temps would be nice to see. 

 

For now I'd say try to close all background programs and see if that helps. 

is this what you needed to see ?

 

650913458_gyazovram.png.1f5211863a5e7a3a59ac6572c016a431.png

task manager gyazo.png

Link to post
Share on other sites
16 hours ago, VeganJoy said:

coffee lake i5 cpus and many other non hyperthreaded chips suffer from microstutter in a lot of games, especially the locked, low speed ones like the 9400. this is compounded by your ram not being able to run at full speed, a b365 motherboard limits you to 2666mhz instead of 3200mhz. i'm not aware of anything you can do to alleviate this stuttering with your current hardware, maybe someone else here has good ideas

im confuse because i have friend that has the same computer as me and he doesnt have any problems at all (we play the same games and everything)

Link to post
Share on other sites
5 minutes ago, Vegeny said:

is this what you needed to see ?

 

 

 

Lmao yes, thanks. 

 

For what I can tell it looks all good. The stutters are so rare and random that I think it's either a background program acting up or the game itself having issues. 

Can you:

1. Make sure nothing else is running 

2. Reinstall the game

And see if that helps? 

 

Also it seems there's one spike in the wifi activity. Can you switch to wired and see if that helps? Also, dies this occure only in online gaming or also offline? You only mention this one game but in the OP you say all games. What kind of games? 

Gaming HTPC:

R7 1700X - Scythe Big Shuriken 3 - Asus ROG B350-i - Asus GTX 1080 Strix - 16gb G.Skill Ripjaws V 3333mhz - Silverstone SX500-LG - 500gb 960 EVO - Fractal Design Node 202 - Samsung 60KS7090 - Logitech G502 - Thrustmaster T500RS - Noblechairs Icon


Desktop PC:
R9 3900X - H100i GTX - Asus Prime X570 Pro - EVGA RTX2060KO - 32gb LPX 3200mhz - EVGA 750G2 - 250gb 970 Evo - 6TB WD My Book Duo (Reds) - Inwin 103 White - Dell U3415W - Qpad MK-85 Brown - Logitech MX518 Legendary - Blue Yeti Platinum - Noblechairs Icon 


Boss-NAS [Build Log]:
R5 2400G - Noctua NH-D14 - Asus Prime X370-Pro - 16gb G.Skill Aegis 3000mhz - Seasonic Focus Platinum 550W - Fractal Design R5 - 
250gb 970 Evo (OS) - 2x500gb 860 Evo (Raid0) - 6x4TB WD Red (RaidZ2)

 

Audio Gear:

Hifiman HE-400i - Kennerton Magister - Beyerdynamic DT880 250Ohm - AKG K7XX - Fostex TH-X00 - O2 Amp/DAC Combo - 
Klipsch RP280F - Klipsch RP160M - Klipsch RP440C - Yamaha RX-V479

 

Reviews and Stuff:

GTX 780 DCU2 // 8600GTS // Hifiman HE-400i // Kennerton Magister
Folding all the Proteins! // Boincerino

Useful Links:
Do you need an AMP/DAC? // Recommended Audio Gear // PSU Tier List 

Link to post
Share on other sites
7 minutes ago, FloRolf said:

Lmao yes, thanks. 

 

For what I can tell it looks all good. The stutters are so rare and random that I think it's either a background program acting up or the game itself having issues. 

Can you:

1. Make sure nothing else is running 

2. Reinstall the game

And see if that helps? 

 

Also it seems there's one spike in the wifi activity. Can you switch to wired and see if that helps? Also, dies this occure only in online gaming or also offline? You only mention this one game but in the OP you say all games. What kind of games? 

i mostly play onlines games i never offline games ima try right now tho

Link to post
Share on other sites
27 minutes ago, Vegeny said:

i mostly play onlines games i never offline games ima try right now tho

 

34 minutes ago, FloRolf said:

Lmao yes, thanks. 

 

For what I can tell it looks all good. The stutters are so rare and random that I think it's either a background program acting up or the game itself having issues. 

Can you:

1. Make sure nothing else is running 

2. Reinstall the game

And see if that helps? 

 

Also it seems there's one spike in the wifi activity. Can you switch to wired and see if that helps? Also, dies this occure only in online gaming or also offline? You only mention this one game but in the OP you say all games. What kind of games? 

I just tried all my games and i got no offline games lmao im going to try with Ark tomorrow i have to download it again

 

but you also said " that your CPU usage is on par or higher than your GPU usage, which is usually bad." is there a fix for that ? Also i removed all background apps and i already reinstalled the game twice but stutters continue in every games. Im starting to think its either a wifi problem or the gpu and cpu usage thingy u were talking about.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×