Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

TP-Link UH720 USB hub issues on audio devices

xgiaime
 Share

Dear all,

I'm running Windows 10 Pro on an Asus Z-170A motherboard.

I just purchased the aforementioned usb hub, and tried 2 different audio devices on it (Logitech G533 wireless headphones and an old USB DAC) and they don't work, sometimes there's some crackle, sometimes the program that's playing audio freezes, sometimes the device is not recognized.

I've tried every port on both the hub and the PC (USB 2.0 on Intel usb device, USB 3.0 on Intel usb device, USB 3.1 on ASMedia usb devices - I also tried rolling back to 2018 and 2016 drivers for the ASMedia) and it still doesn't work.

Every other USB device (mouse, hdds, sticks...) works ok.

I'm asking on the forum before returning it because it works 100% flawlessy when connected to my work PC, a Dell laptop.

Am I out of luck or is there something I can try?

Link to comment
Share on other sites

Link to post
Share on other sites

  • 1 month later...

Sorry you haven't gotten an answer yet. Found this because I'm also having issues with this hub. I may be wrong about what's happening, or what caused what. But here's what appears to have happened:

 

Had very bad audio issues with wired and wireless USB headphones until I removed the power supply. Running from USB bus power only, everything seems fine.

 

Recently unplugged the USB on accident. After plugging back in, all devices were disconnecting every few seconds. Keyboard, mouse, and wireless headset dongle. Went so far as to unplug them all, remove from device manager, reboot, and replug. Didn't help. The only fix was to move the dongle off the hub, to the PC front port.

 

Then it got weird. Without a touchy audio device complaining, I thought I'd put the power plug back for better USB charging. Don't remember what problem that caused or why I rebooted, but it would not boot. At all. I could get into the bios only if I used safeboot. Anything else just hung before it could post. Solution was to re-flash the bios. Thank goodness for a board made for over clocking with easy fail-safes.

 

Needless to say, I had removed the power cord again by this point.

 

Hope someone else sees this and has a solution. Or just a lead on a good solid hub that's worth buying. 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×