Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Poor performance with 2070 super

Matt_J
 Share

Hello,

 

PC specs:

i7-8700k 3.7 GHz 

EVGA GeForce RTX 2070 super

Corsair vengeance 2x8 gb DDR4 3000 MHz (16 gb total)

 

MSI Z370 PC PRO LGA 1151 (300 Series) Intel Z370 SATA 6Gb/s USB 3.1 ATX Intel Motherboard

water cooled

 

I built my pc and am experiencing what i feel as sub par performance in games. For example, my friends who have gtx 1070 and gtx 970's are outperforming me in games such as Sea of Thieves with the same graphics settings. On rare settings (medium) i average below 60 fps whereas my previously stated frames average about 80 fps. Also, i experience large drops in fps games whereas my friends do not. I ran a benchmark using UserBenchmark, the results are shown below. I'm thinking it's a cpu or motherboard issue. Sea of Thieves is installed on my SSD now, i think i'll try reinstalling it on my hard drive. 

 

UserBenchmarks: Game 73%, Desk 46%, Work 39%
CPU: Intel Core i7-8700K - 47.8%
GPU: Nvidia RTX 2070S (Super) - 102.1%
SSD: Kingston A400 240GB - 31.5%
HDD: Seagate Barracuda 2TB (2018) - 96.6%
RAM: Corsair Vengeance LPX DDR4 3000 C15 2x8GB - 53.9%
MBD: MSI Z370 PC PRO (MS-7B49)

 

Thanks,

Matt

 

Link to comment
Share on other sites

Link to post
Share on other sites

Resolution? Do you have all your appropriate drivers? Temperatures? What does cpu and gpu usage look like in game?

 

Don't use userbenchmark.

 

Community Standards || Tech News Posting Guidelines

---======================================================================---

CPU: R5 3600 || GPU: RTX 3070|| Memory: 32GB @ 3200 || Cooler: Scythe Big Shuriken || PSU: 650W EVGA GM || Case: NR200P

Link to comment
Share on other sites

Link to post
Share on other sites

I run Sea of Thieves at 1080p on my 1080p 144 Hz monitor. My drivers are up to date. My cpu usage is like 15% and gpu is 45% in game which is way lower than my friends (they are at like 60% for both cpu and gpu) and what i would expect. If i remember correctly my cpu cores were all in the 25-30 celsius range and gpu was at like 45 celsius but i don't know how long i had the game open for when i looked at those. 

Link to comment
Share on other sites

Link to post
Share on other sites

but also, any cpu temperature software i try to use like openhardware doesn't show my cpu temps sometimes, like right now it just doesn't display any temperatures. i've tried two other softwares and same issue, they only show utilization not temps

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, Matt_J said:

but also, any cpu temperature software i try to use like openhardware doesn't show my cpu temps sometimes, like right now it just doesn't display any temperatures. i've tried two other softwares and same issue, they only show utilization not temps

Are your fans / cooling working properly? If they're not doing their job the CPU will throttle.

Link to comment
Share on other sites

Link to post
Share on other sites

i believe they are all working, all of them are always spinning and i have front to back airflow across the case

Link to comment
Share on other sites

Link to post
Share on other sites

Run HWMonitor - what GPU utilization are you getting?

 

Also, which slot is your GPU attached to on the mobo?

Link to comment
Share on other sites

Link to post
Share on other sites

The gpu is in the top slot and i get 40-45% gpu utilization in game according to HWMonitor

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×