Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

RGB LIGHTING

nicomaga98
 Share

Hello, 

 

I just received my pc yesterday and only 2/3 fans have lighting working. All 3 fans are spinning but the top fan does not have any light. I do not see any disconnected wires. I have a picture below. Any help please

rgb.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

do you know the fan model(s) are you sure they are all the same? do you have more pictures?

Link to comment
Share on other sites

Link to post
Share on other sites

iBUYPOWER 240mm Addressable RGB Liquid Cooling System

Link to comment
Share on other sites

Link to post
Share on other sites

they are all the same. What picture would help?

Link to comment
Share on other sites

Link to post
Share on other sites

actually in a way you helped me figure out the problem. I took a pic of the fans from the front and just noticed that they did not put LED lights on the top fan. Thats so frusturating. It took a month to get here and they said any repairs will take 4-5 weeks. Hopefully they can just send the LED light here

Link to comment
Share on other sites

Link to post
Share on other sites

great that we found the problem. sorry about the time line your facing

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Newegg

×