Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

GPU not allowing PC to boot.

SleepySEAL
 Share

I recently bought a used R9 270 for a budget gaming rig but im having trouble after powering on.
The PC boots and displays video fine when booting with the integrated  graphics on the mobo, peripherals light up and i make it to the desktop.
once the gpu is connected the Fans On the pc cpu and gpu all spin but i get no video display, peripherals do not light up.
I Have tried the gpu on 3 different working rigs and it does the same on all of them.
I have also tried a different GPU on the affected rig and it also boots up fine.

is there anything else than can be done or is the GPU toast? thank you for the help

Link to comment
Share on other sites

Link to post
Share on other sites

5 minutes ago, PatrikYT_98 said:

try another pcie slot 

my motherboard only has one pcie slot, but i have tried a different gpu on the same rig and had it work perfectly fine with no problems 

Link to comment
Share on other sites

Link to post
Share on other sites

28 minutes ago, SleepySEAL said:

my motherboard only has one pcie slot, but i have tried a different gpu on the same rig and had it work perfectly fine with no problems 

Try updating the firmware on your GPU

PC: Motherboard: ASUS B550M TUF-Plus, CPU: Ryzen 3 3100, CPU Cooler: Arctic Freezer 34, GPU: GIGABYTE WindForce GTX1650S, RAM: HyperX Fury RGB 2x8GB 3200 CL16, Case, CoolerMaster MB311L ARGB, Boot Drive: 250GB MX500, Game Drive: WD Blue 1TB 7200RPM HDD.

 

Peripherals: GK61 (Optical Gateron Red) with Mistel White/Orange keycaps, Logitech G102 (Purple), BitWit Ensemble Grey Deskpad. 

 

Audio: Logitech G432, Moondrop Starfield, Mic: Razer Siren Mini (White).

 

Phone: Pixel 3a (Purple-ish).

 

Build Log: 

Link to comment
Share on other sites

Link to post
Share on other sites

22 minutes ago, TofuHaroto said:

Try updating the firmware on your GPU

how would i go about update the firmware without being able to boot?

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, SleepySEAL said:

how would i go about update the firmware without being able to boot?

Try if possible booting into safe mode if that doesn't work 

Use your i-gpu to display an image then download it and try to flash it 

PC: Motherboard: ASUS B550M TUF-Plus, CPU: Ryzen 3 3100, CPU Cooler: Arctic Freezer 34, GPU: GIGABYTE WindForce GTX1650S, RAM: HyperX Fury RGB 2x8GB 3200 CL16, Case, CoolerMaster MB311L ARGB, Boot Drive: 250GB MX500, Game Drive: WD Blue 1TB 7200RPM HDD.

 

Peripherals: GK61 (Optical Gateron Red) with Mistel White/Orange keycaps, Logitech G102 (Purple), BitWit Ensemble Grey Deskpad. 

 

Audio: Logitech G432, Moondrop Starfield, Mic: Razer Siren Mini (White).

 

Phone: Pixel 3a (Purple-ish).

 

Build Log: 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Newegg

×