Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

No Signal to Monitor

Orange The Hacker
 Share

New PC, all fans spin and lights turn on but monitor says no signal. I've tried onboard and GPU graphics, tried reseating GPU and reseating RAM. When the GPU is taken out the monitor displays "check input cable". All parts are brand new, and the monitor is known good with only one input so its not on the wrong one.

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Orange The Hacker said:

New PC, all fans spin and lights turn on but monitor says no signal. I've tried onboard and GPU graphics, tried reseating GPU and reseating RAM. When the GPU is taken out the monitor displays "check input cable". All parts are brand new, and the monitor is known good with only one input so its not on the wrong one.

There's only one input? What input type is it?

The Louvre

Lian-Li PC-O11 DW   |   ZOTAC RTX 2080   |   Core i5 9600k   |   SeaSonic FOCUS Plus 650W Platinum   |   MSI MPG Z390 Gaming Pro Carbon  |  2x16Gb TRIDENT Z ROYAL  |   2xSX8200 240Gb NVME SSD's  |   1x Seagate Firecuda 1TB   |   EVGA Closed Loop Cooler 280mm   |   1x MSI MPG27C Monitor

Link to comment
Share on other sites

Link to post
Share on other sites

Do you know if your PC is posting at all? That can be an entirely different pain to deal with.

Are you using VGA/analog adapters? I think most GPUs today do not support analog signals, including the DVI port. If you're converting DVI to VGA to your monitor that might be the problem.

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, Orange The Hacker said:

New PC, all fans spin and lights turn on but monitor says no signal. I've tried onboard and GPU graphics, tried reseating GPU and reseating RAM. When the GPU is taken out the monitor displays "check input cable". All parts are brand new, and the monitor is known good with only one input so its not on the wrong one.

also what monitor is it and what are the pc specs

The Louvre

Lian-Li PC-O11 DW   |   ZOTAC RTX 2080   |   Core i5 9600k   |   SeaSonic FOCUS Plus 650W Platinum   |   MSI MPG Z390 Gaming Pro Carbon  |  2x16Gb TRIDENT Z ROYAL  |   2xSX8200 240Gb NVME SSD's  |   1x Seagate Firecuda 1TB   |   EVGA Closed Loop Cooler 280mm   |   1x MSI MPG27C Monitor

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, CharminUltraStrong said:

There's only one input? What input type is it?

Specs are as follows: B350M PRO-VDH, Gtx 1060, Ryzen 3 1200, EVGA 500W PSU, idk case/storage models

Link to comment
Share on other sites

Link to post
Share on other sites

9 hours ago, Orange The Hacker said:

Specs are as follows: B350M PRO-VDH, Gtx 1060, Ryzen 3 1200, EVGA 500W PSU, idk case/storage models

Well there's your first problem, Ryzen 3 1200 doesn't have integrated graphics so you wouldn't be able to connect to an onboard GPU. As far as the GPU, I've had issues where mine needed to be plugged in and setup over HDMI first before I could utilize display port.

The Louvre

Lian-Li PC-O11 DW   |   ZOTAC RTX 2080   |   Core i5 9600k   |   SeaSonic FOCUS Plus 650W Platinum   |   MSI MPG Z390 Gaming Pro Carbon  |  2x16Gb TRIDENT Z ROYAL  |   2xSX8200 240Gb NVME SSD's  |   1x Seagate Firecuda 1TB   |   EVGA Closed Loop Cooler 280mm   |   1x MSI MPG27C Monitor

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×