Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

omen 32" refresh rate lock

koni_sk
 Share

So hello guys,

in october i bought the omen by hp 32" 2k@75hz monitor (https://store.hp.com/us/en/pdp/omen-by-hp-32-32-inch-display)

and i would like to overclock it but there is weird safety lock or something , when i set it on refresh rate higher than 75hz , window will show saying that "out of range, going to sleep mode in 30 seconds"

and i dont know what to do , i tryed contacting the support too but with no luck

also sorry for the phone picture but i cant screenshot the black window cuz its the monitor thing

thanks!

IMG_20181224_013907.thumb.jpg.7e41e5884f43a720ab5a31278f4d68af.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

Quote

i3uu:

I have an Nvidia GPU so if you have the same, follow along. If its AMD then the directions will be slightly different.

in the Nvidia control panel (right click on desktop) go to the option "Change resolution". Click on 'OMEN by HP 32' and then click on the box below called 'Customize...' A new box will open and then click 'Create Custom Resolution'. In the NEW window, Just raise the 'Refresh rate' from 60 to whatever you want. It's safest to start with smaller jumps so I'd recommend going up by 10-15 Hz and then click 'Test' below. I was able to get 120 Hz but as soon as I set it to 121, all of my screens went black and I needed to restart the computer. That's a tell tale sign of going past the limit. It shouldn't do anything bad to your monitor, just do a hard reboot of the PC and it will change back.

Every once in awhile(very rare) it will say something like 'Resolution not supported' on my monitor and I have to lower the Hz, and then re-raise it until it stops bothering me. You can also try overclocking your other monitors with this same method. My older 60hz monitors can get to 75hz before it blacks out. You can test your refresh with this: https://www.testufo.com/

Cheers!

Quote from here: https://www.reddit.com/r/Monitors/comments/76sq8i/hp_omen_32_overclocking/

 

But then I found this: https://www.monitortests.com/forum/Thread-Omen-32-monitor-out-of-range-message-any-way-to-around-it

In short, the person there says it's not possible to as it's a monitor firmware limitation.

 

Hope this helps.

Link to comment
Share on other sites

Link to post
Share on other sites

9 hours ago, TempestCatto said:

yeah i tryed that thing , lowering the refresh rate and then raising it back up but with no luck , and there must be a way to bypass that thing :(

 

Link to comment
Share on other sites

Link to post
Share on other sites

  • 10 months later...

Sorry to bump but I have a friend who has tried to do the above but is met with an out of range monitor error on the monitor itself and not a windows error. Unfortunately this workaround did not work for him at 120hz, the highest achieved was 100hz but even that was too much as you could see the flickering very easily and water marks like dirt on the screen. Its optimum highest setting at full resolution at 1440x2560 was at 90hz.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×