Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

DNS resolver issues on select sites with VPN connected

RAS_3885
 Share

I have a strange DNS resolver issue that I can't seem to wrap my head around.  I'm running a dedicated pfSense box with an OpenVPN client configured per PIA's instructions HERE.  Everything is connected and running as expected, however, I've come across a small number of sites that for whatever reason return a DNS error and fail to resolve/load. I'm talking a number of sites I can count on one hand.  Two that come up frequently have been forum.netgate.com and extremeoverclocking.com (and all sub-domains of that site, like folding.extremeoverclocking.com).  They also fail to resolve using nslookup via a command prompt, unless I force them to use something like Google's DNS, then they resolve fine.

 

I've confirmed that disconnecting the VPN allows the above sites to resolve fine.  Why would only a few sites fail DNS lookup when all others work fine?  I'm very much new to playing around with pfSense and still don't fully understand HOW the VPN client re-configures the routing tables and DNS requests, so I'm sure there's something I'm missing.

 

Thanks in advance!

Be sure to QUOTE or TAG me in your reply so I see it!

 

CPU Ryzen 5 5600x GPU EVGA 3080 Ti FTW3 Ultra MOBO Asus ROG Strix B550-F Gaming RAM Crucial Ballistix 3600 MHz CL16 32 GB PSU Corsair RM1000x COOLING Noctua NH-U12S

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×