Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Cannot output audio to both of monitor connected via hdmi

 Share

Hi Guys,

 

Currently i have 2 monitors connected  (1 via  HDMI and other  via display port)  which are audio capable. But i am able to output  audio from single monitor.

 

Need help to output audio from both monitors.

 

Specs:

Ryzen 2700x

Aorous Ultra Gaming  x470

Zotac 1070ti AMP

 

Audio.png

Link to comment
Share on other sites

Link to post
Share on other sites

Right click the audio icon and go to properties. You should be able to set your default audio device.

As a last resort you could get a set of cheap desk speakers like these.

Link to comment
Share on other sites

Link to post
Share on other sites

If you're trying to get audio to output both to the same time, e.g., if you're playing a video, the audio goes out both, you can't.

 

If you're trying to get some apps to play out on one monitor or the other, there's no easy way to do it as far as I know. The only way I know how is before you start the app or whatever is to switch which audio you want to output to, then the app will use that audio output.

Link to comment
Share on other sites

Link to post
Share on other sites

15 minutes ago, M.Yurizaki said:

If you're trying to get audio to output both to the same time, e.g., if you're playing a video, the audio goes out both, you can't.

 

If you're trying to get some apps to play out on one monitor or the other, there's no easy way to do it as far as I know. The only way I know how is before you start the app or whatever is to switch which audio you want to output to, then the app will use that audio output.

Yes i want audio output from  both monitors at same time. Is there absolutely no way?

 

Link to comment
Share on other sites

Link to post
Share on other sites

23 minutes ago, JammyCreedog said:

Right click the audio icon and go to properties. You should be able to set your default audio device.

As a last resort you could get a set of cheap desk speakers like these.

Doing these only enables 1 speaker at a time but both my monitors have  speakers and  i want to utilize them.

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, AthenianWarlord said:

Yes i want audio output from  both monitors at same time. Is there absolutely no way?

 

Do the monitors have an aux in (3.5mm in)?  Maybe you could do that and run it off a splitter if so.

 

I don't think even if you chained DisplayPort monitors that you can get audio through the display cables to both monitors though.

 

Might also be able to use a stereo mix option depending on your sound chip/software, like in Realtek's software.

 

Maybe a program like Virtual Audio Cable?

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, PineyCreek said:

Do the monitors have an aux in (3.5mm in)?  Maybe you could do that and run it off a splitter if so.

 

I don't think even if you chained DisplayPort monitors that you can get audio through the display cables to both monitors though.

 

Might also be able to use a stereo mix option depending on your sound chip/software, like in Realtek's software.

 

Maybe a program like Virtual Audio Cable?

Yes My monitor does have an 3.5 jack, how to set  up?

Link to comment
Share on other sites

Link to post
Share on other sites

9 minutes ago, AthenianWarlord said:

Doing these only enables 1 speaker at a time but both my monitors have  speakers and  i want to utilize them.

Actually in usual fashion of mine, I went about to see if this was really impossible.

 

Turns out there's a workaround, if you have this option available:

  1. Go to your Sound options ( In Control Panel\All Control Panel Items -> Sound)
  2. Go to the Recording tab
  3. Right click on a blank area and select "Show disabled devices"  if it's not checked
  4. If you have something called "Wave Out", "Stereo Mix" or something, enable it, then set it as the default device (both options in the right click menu)
  5. Right click on whatever you have enabled, select Properties, then go to the Listen tab.
  6. Check off the box "Listen to this device"
  7. In the "Playback through this device" drop down, select the other monitor

If you do not have the option described in 4 or it doesn't work out for some reason, then you have to use a virtual aux cable app like https://www.vb-audio.com/Voicemeeter/index.htm

 

Otherwise, a "set and forget" sort of thing isn't doable.

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, M.Yurizaki said:

Actually in usual fashion of mine, I went about to see if this was really impossible.

 

Turns out there's a workaround, if you have this option available:

  1. Go to your Sound options ( In Control Panel\All Control Panel Items -> Sound)
  2. Go to the Recording tab
  3. Right click on a blank area and select "Show disabled devices"  if it's not checked
  4. If you have something called "Wave Out", "Stereo Mix" or something, enable it, then set it as the default device (both options in the right click menu)
  5. Right click on whatever you have enabled, select Properties, then go to the Listen tab.
  6. Check off the box "Listen to this device"
  7. In the "Playback through this device" drop down, select the other monitor

If you do not have the option described in 4 or it doesn't work out for some reason, then you have to use a virtual aux cable app like https://www.vb-audio.com/Voicemeeter/index.htm

 

Otherwise, a "set and forget" sort of thing isn't doable.

Lol, I suspect you were writing that when I put out my part... :D  Glad you provided more details though.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×