Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
rpalmz46

Can someone please help me with my PC

Recommended Posts

Posted · Original PosterOP

So I recently just got a 3080 from a order list at a store and its a msi ventus, after installing it, i was testing games out and it was working good and then i noticed progressively the gpu usage was kind of low and was boggled by that so went to try and find out why. After many driver installs later now when i use my pc loading my ssds or any drives are laggy, and games just chop in and out. I figured maybe my 3080 was messing something up but i put my old card which worked today back in and its doing the same thing. Only thing i can think of is my motherboards usbs were working today and they are a bit screwy and whenever they die it stops many of my basic pc functions from working right such as when i try to shut down it freezes at the circle spinning logo. I try to exit bios it freezes i have to restart pc manually. When the usbs work again all of this stuff ceases to be a problem. Sorry for the structure of this paragraph just at my wits end trying to figure out what to do. Only thing i can think of is my motherboard is shitting the bed on me otherwise i have no idea what is going on. I tried reseating the ram and taking out the battery didn't seem to do anything.

 

I am also using a pcie usb hub to be able to consistently use my usbs for power i was wondering if this had something to do with it but wasnt sure since i cant use my pc without it.

 

My specs:

i5-8600k

corsair rm750x

msi z370 gaming plus motherboard

gskill ddr4 2400mhz 16gb

 

Link to post
Share on other sites

If I were you I would give my PC a fresh start. Format and install everything, then work from there.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, w1nger1 said:

If I were you I would give my PC a fresh start. Format and install everything, then work from there.

yep basically where i am at at the moment this is annoying i dont understand what could be wrong apart from mobo didnt want to have to replace until i upgraded to a ryzen chip in the future but yay now after spending 1200$ on a 3080 i get to spend another 800$ so soon

Link to post
Share on other sites

From what you have given, it could be many things, sometimes it is hard to find a fault if you are running everything. If you suspect a cause, try single it out and eliminate other components. Like if you think something wrong with the USB port, try not plug everything in and test it individually, see if the problem sticks or not.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×