Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Worboys51

Asrock B450M Steel Legend help

Just now, Worboys51 said:

Hi all, I have built my first gaming pc (on a budget) about a month ago. Running an Asrock B450M Steel Legend MOBO, with a ryzen 3300X cpu. I am running in to an issue where I wanted to use the USB C port on the motherboard, however when anything is plugged in I don’t receive anything in windows other than “this USB device is not working properly”. Every other USB port is working flawlessly, both on the MOBO and the case. 
 

Please help with some suggestions, I am not the best computer wiz but I think I can muster my way around what needs doing once I receive some advice. I have checked the bios settings but nothing seems obvious, and after numerous google searches I figured I might as well create an account, and see if my first post here could be a success! 
 

If I have left out any other relevant information, please see ask for required specs :) 

bios upto date and all drivers for mb ?

 

Recommended Posts

Posted · Original PosterOP

Hi all, I have built my first gaming pc (on a budget) about a month ago. Running an Asrock B450M Steel Legend MOBO, with a ryzen 3300X cpu. I am running in to an issue where I wanted to use the USB C port on the motherboard, however when anything is plugged in I don’t receive anything in windows other than “this USB device is not working properly”. Every other USB port is working flawlessly, both on the MOBO and the case. 
 

Please help with some suggestions, I am not the best computer wiz but I think I can muster my way around what needs doing once I receive some advice. I have checked the bios settings but nothing seems obvious, and after numerous google searches I figured I might as well create an account, and see if my first post here could be a success! 
 

If I have left out any other relevant information, please see ask for required specs :) 

Link to post
Share on other sites
Posted · Best Answer
Just now, Worboys51 said:

Hi all, I have built my first gaming pc (on a budget) about a month ago. Running an Asrock B450M Steel Legend MOBO, with a ryzen 3300X cpu. I am running in to an issue where I wanted to use the USB C port on the motherboard, however when anything is plugged in I don’t receive anything in windows other than “this USB device is not working properly”. Every other USB port is working flawlessly, both on the MOBO and the case. 
 

Please help with some suggestions, I am not the best computer wiz but I think I can muster my way around what needs doing once I receive some advice. I have checked the bios settings but nothing seems obvious, and after numerous google searches I figured I might as well create an account, and see if my first post here could be a success! 
 

If I have left out any other relevant information, please see ask for required specs :) 

bios upto date and all drivers for mb ?

 


CPU - R9 3900X | CPU Cooler - NZXT Kraken X73 360MM | Motherboard -  ASRock x570 Steel Legend | RAM -G.SKILL Trident Z (4x16GB) 3600Mhz CL16 | Graphics Card - MSI 1660 Armour OC 6GB (Sold my 2080 super so i can go 3000 series)  | Power Supply - Cooler Master V-series 1200 Platinum | Storage - 

500GB Evo 970 plus NVME - OS Drive | Aorus Gen4 AIC Adaptor 2x A2000 1TB Raid 0 - Steam Games Drive3 x 2TB WD Black HDD Raid 0 - Program Drives/Games Over Flow Drive 2x 4TB Segate HDD Raid 0 - Plex Drive Case - 

Phantek Enthoo Pro | Fans - CRYORIG QF120 Performance PWM Fan 120mm, 600-2200RPM x 7

 

Operating System - Windows 10 Pro

 

Network - Asus 5300AC -----> TP-Link TL-SG1024 24-Port Gigabit Unmanaged Switch -----> Ubiquiti UniFi UAP-AC-LITE Dual-band AC1200 x3 | Slowly working to 10Gbps but this set up now happily takes my 1Gbps connection :P 

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Escapenz said:

bios upto date and all drivers for mb ?

 

Im pretty sure all the drivers are up to date, but have been too nervous to go ahead with a bios update. Is there a simple software or way to verify everything is up to date? Was hoping that Bios update would be a last resort as I really don’t want to screw it up! 

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, Escapenz said:

bios upto date and all drivers for mb ?

 

Thank you very much, I, very nervously, carried out a bios update. All went well, and USB C port now works!! Huzzah!!!

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×