Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TaZKobRa

Cannot remove drive letter assigned to non-existent drive

Thank you all for the help. I must say that I'm sorry, but all this was being caused due to "PowerISO". It made a virtual drive on E, and apparently Ejecting it doesn't work, unmounting it doesn't work. To heck with all these retarded software vendors in this day and age where they can't do as simple as dismounting a drive when it is not being used. Learned a lot about a lot of stuff. Thanks :)

Recommended Posts

Posted · Original PosterOP

TL;DR I cannot assign my new SSD volume to E: because apparently E: is assigned to something that isn't there.

 

I just got a new SSD and wanted to assign it the drive letter E:. For a few years now, my drive letters have been C:, D:, F:, G:. I had a CD-Drive earlier, which maybe was assigned to E:. I don't really remember. Anyways, since CDFG was bugging the heck out of me, I of course wanted to assign E: to my new SSD volume. When I created a new volume on the SSD with E: in "Disk Management"(dskmgmt.exe), the volume was created but it could not be assigned E:. Fair. I went into DiskPart. Tried assigning the new volume E:. Gives me the error,

 

"Virtual Disk Service error:

The specified drive letter is not free to be assigned."

 

I recheck my volume list and do not find E: assigned to anything. So I go to remove it and get the error,

 

"DiskPart has encountered an error: The device is not ready.

See the System Event Log for more information."

 

I'm just pissed off at this point. I check device manager to see if some janky virtual drive is in the way or something. Nothing.

I go check the Registry, under HKEY_LOCALL_MACHINE\SYSTEM\MountedDevices I find an entry of the name "\DosDevices\E:" with some value assigned to it. Neither do I read Hexa properly, nor do I have any knowledge of this stuff. Had an idea of deleting this value to free up the drive letter, but I obviously don't want to be deleting stuff from the Registry without knowing what I'm exactly doing.

 

I just want my drives to read C D E F G, not C D F G H or something obnoxious of this sort. HELP please!

Link to post
Share on other sites

Open Computer, on the toolbar click View and tick Hidden Items. Anything show up thats using E?

 

You got any card readers installed? Its possible one of those is using it.

 

Also its possible E has already been assigned to a USB device in which case Windows will reserve it.


Main Rig:-

Ryzen 7 3800X | Asus ROG Strix X570-F Gaming | 16GB Team Group Dark Pro 3600Mhz | Corsair MP600 1TB PCIe Gen 4 | Sapphire 5700 XT Pulse | Corsair H115i Platinum | WD Black 1TB | WD Green 4TB | EVGA SuperNOVA G3 650W | Asus TUF GT501 | Samsung C27HG70 1440p 144hz HDR FreeSync 2 | Windows 10 Pro X64 |

 

Server:-

Intel NUC running Server 2019 + Synology DSM218+ with 2 x 4TB Toshiba NAS Ready HDDs (RAID0)

Link to post
Share on other sites
Posted (edited) · Original PosterOP

I kid you not, I just clicked on the View button in the toolbar and CD-Drive(E:) appeared out of nowhere. I haven't seen it since I took out my cd drive and used to it hold the coals for a BBQ a few years back. But how do I remove it?

 

P.S. Tried ejecting it, says "An error occurred while ejecting Cd Drive(E:)". Well no sht sherlock. Where can I actually get some info on these errors?

Edited by TaZKobRa
Link to post
Share on other sites
Just now, TaZKobRa said:

I kid you not, I just clicked on the View button in the toolbar and CD-Drive(E:) appeared out of nowhere. I haven't seen it since I took out my cd drive and used to it hold the coals for a BBQ a few years back. But how do I remove it?

Open device manager, and show hidden devices. Then check DVD/CD-ROM drives listed there. Remove any faded out ones. Same for Disk Drives.

Link to post
Share on other sites

Open command prompt as admin then type in "diskpart" and hit enter. Next type "automount scrub" and hit enter. Finally type "exit" and hit enter. Now reboot your PC.


Main Rig:-

Ryzen 7 3800X | Asus ROG Strix X570-F Gaming | 16GB Team Group Dark Pro 3600Mhz | Corsair MP600 1TB PCIe Gen 4 | Sapphire 5700 XT Pulse | Corsair H115i Platinum | WD Black 1TB | WD Green 4TB | EVGA SuperNOVA G3 650W | Asus TUF GT501 | Samsung C27HG70 1440p 144hz HDR FreeSync 2 | Windows 10 Pro X64 |

 

Server:-

Intel NUC running Server 2019 + Synology DSM218+ with 2 x 4TB Toshiba NAS Ready HDDs (RAID0)

Link to post
Share on other sites
Posted · Original PosterOP
7 minutes ago, TehDwonz said:

Open device manager, and show hidden devices. Then check DVD/CD-ROM drives listed there. Remove any faded out ones. Same for Disk Drives.

No DVD/CD-ROM drives listed there at all. But windows really needs to make a windows version with no hidden stuff. Too much stuff is hidden.

 

6 minutes ago, Master Disaster said:

Open command prompt as admin then type in "diskpart" and hit enter. Next type "automount scrub" and hit enter. Finally type "exit" and hit enter. Now reboot your PC.

Gonna try it and let you know.

Link to post
Share on other sites
Posted · Original PosterOP

And it doesn't work. When I open explorer, CD Drive (E:) is still there. ANything else I might try?

Link to post
Share on other sites

Theres one other option, open a command prompt as admin and do "mountvol /R" followed by a system restart however this might also remove some of your other drive letters. It won't affect the C drive and the other drives can then be reassigned as you need them.


Main Rig:-

Ryzen 7 3800X | Asus ROG Strix X570-F Gaming | 16GB Team Group Dark Pro 3600Mhz | Corsair MP600 1TB PCIe Gen 4 | Sapphire 5700 XT Pulse | Corsair H115i Platinum | WD Black 1TB | WD Green 4TB | EVGA SuperNOVA G3 650W | Asus TUF GT501 | Samsung C27HG70 1440p 144hz HDR FreeSync 2 | Windows 10 Pro X64 |

 

Server:-

Intel NUC running Server 2019 + Synology DSM218+ with 2 x 4TB Toshiba NAS Ready HDDs (RAID0)

Link to post
Share on other sites

Going back to the Device Manager suggestion, did you click View and then Show Disabled Devices before you looked for the CD Drive?


Main Rig:-

Ryzen 7 3800X | Asus ROG Strix X570-F Gaming | 16GB Team Group Dark Pro 3600Mhz | Corsair MP600 1TB PCIe Gen 4 | Sapphire 5700 XT Pulse | Corsair H115i Platinum | WD Black 1TB | WD Green 4TB | EVGA SuperNOVA G3 650W | Asus TUF GT501 | Samsung C27HG70 1440p 144hz HDR FreeSync 2 | Windows 10 Pro X64 |

 

Server:-

Intel NUC running Server 2019 + Synology DSM218+ with 2 x 4TB Toshiba NAS Ready HDDs (RAID0)

Link to post
Share on other sites
Posted · Original PosterOP

There is no "Show Disabled Devices" in the View dropdown. 5 sort options, a "Show hidden devices" checkbox, and Customize for UI customization. If you meant the show hidden devices checkbox, yes, I checked it before looking. Nothing. 

image.png

 

P.S. I have 4 drives. 2 SSDs, 2 HDDs. Nothing else shows up, not even a category for cd drives.

Link to post
Share on other sites
Just now, TaZKobRa said:

There is no "Show Disabled Devices" in the View dropdown. 5 sort options, a "Show hidden devices" checkbox, and Customize for UI customization. If you meant the show hidden devices checkbox, yes, I checked it before looking. Nothing. 

 

ok, I forgot I have an environment variable set :)
 

open an admin command prompt and type:

set devmgr_show_nonpresent_devices=1

Reboot. Then try the hidden devices again.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, TehDwonz said:

ok, I forgot I have an environment variable set :)
 

open an admin command prompt and type:


set devmgr_show_nonpresent_devices=1

Reboot. Then try the hidden devices again.

On it. Hope it works.

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, TehDwonz said:

ok, I forgot I have an environment variable set :)
 

open an admin command prompt and type:


set devmgr_show_nonpresent_devices=1

Reboot. Then try the hidden devices again.

Didn't work. :(

Link to post
Share on other sites
2 minutes ago, TaZKobRa said:

On it. Hope it works.

To verify it added the variable, press [Win]+[Pause/Break], go to Advanced System Settings and click the Environment Variables button.

Spoiler

image.png.c9f893f81ff6cdab1b6b7a9c9f85acbb.png

Then in the System part, you should have this:

Spoiler

image.png.30c00ce0915a78f582b2fcf6039693b4.png

If not, use that interface to add it. No need to reboot using this way.

Link to post
Share on other sites
3 minutes ago, TaZKobRa said:

Didn't work. :(

The other place to try is here:

 

 image.png.823f6f6e86800242682580412f10206d.png

 

Might be worth also booting into safe mode to try assigning the letters?

Link to post
Share on other sites
17 minutes ago, TehDwonz said:

ok, I forgot I have an environment variable set :)
 

open an admin command prompt and type:


set devmgr_show_nonpresent_devices=1

Reboot. Then try the hidden devices again.

For future reference, that should have been "setx" not "set". Setx makes the change permanent, just "set" is removed after a reboot :) 

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, TehDwonz said:

For future reference, that should have been "setx" not "set". Setx makes the change permanent, just "set" is removed after a reboot :) 

Thanks for clearing that up. Was starting to doubt my eyes.

 

Tried both of what you mentioned, removing the devices not present. Nothing works. And adding that value didn't really change anything in device manager. Everything's the same as before, even when I turn on "check hidden devices".

Link to post
Share on other sites
Just now, TaZKobRa said:

Thanks for clearing that up. Was starting to doubt my eyes.

 

Tried both of what you mentioned, removing the devices not present. Nothing works. And adding that value didn't really change anything in device manager. Everything's the same as before, even when I turn on "check hidden devices".

ok, it was just to rule it out as being "extra hidden". Maybe try safe mode next?

Link to post
Share on other sites
Posted · Original PosterOP
14 minutes ago, TehDwonz said:

ok, it was just to rule it out as being "extra hidden". Maybe try safe mode next?

Gonna try it in safe mode. 

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

Thank you all for the help. I must say that I'm sorry, but all this was being caused due to "PowerISO". It made a virtual drive on E, and apparently Ejecting it doesn't work, unmounting it doesn't work. To heck with all these retarded software vendors in this day and age where they can't do as simple as dismounting a drive when it is not being used. Learned a lot about a lot of stuff. Thanks :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×