Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
mekkeron

Windows 10 boot option is gone after installing Ubuntu on a separate HDD

Fixed it!!

 

It seemed that everything was pointing to the fact that the MBR on Windows SSD somehow got erased, so I was able to recover it by following these steps: https://neosmart.net/wiki/fix-mbr/#Fix_the_MBR_in_Windows_10

Even then I had go through additional steps outlined after "If bootrec utility doesn’t fix it..."

 

After that, I had to change boot priority in BIOS to get to Ubuntu (because after following the steps in the link I provided it defaulted it to Windows) and in Ubuntu, I ran the commands that M.Yurizaki mentioned sudo os-prober and sudo update-grub. It detected Windows right away and I am now able to double boot.

 

Thanks, M.Yurizaki and Lukyp for your help.

 

What a relief, I came very close to reinstalling Windows entirely.

Recommended Posts

Posted · Original PosterOP

Yesterday I decided to make a use of an empty 1 TB hard drive I have in my PC and install Ubuntu 18.04 on it, hoping to get the dual-boot option. The installation was successful, however now when I boot up my computer I'm not getting a boot choice between Windows and Ubuntu, it always boots up Ubuntu by default. First I freaked out thinking that I had accidentally installed it on a primary SSD drive on which I have Windows. But then I checked that drive on Ubuntu file system, all the Windows files appear to be in tact.

 

Does anyone know how can I fix it?

Link to post
Share on other sites

You need to update GRUB (assuming this is the bootloader used) on the Ubuntu drive to include the Windows install. Otherwise, you can, on boot, tell the system to boot from the Windows storage drive.

 

Anyway, if you want to try updating GRUB:

  • Open a terminal
  • Type in the commands:
    • sudo apt-get install os-prober
    • update-grub
  • Make sure after issuing "update-grub" it sees Windows. If it does, reboot and it should give you the option to choose.
Link to post
Share on other sites

Are you on EFI? 


Laptops: - Thinkpad x60S, CPU: Core Duo, RAM: 4GB, GPU: Intel 945M.  - Dell XPS 15 9550, i5 6300HQ, 8GB DDR4, Crucial MX500 512GB, GTX 960M
Desktop: CPU: AMD Ryzen 5 1600, RAM: HyperX 2667 OC 4x4GB, GPU: Zotac 1060 3GB Mini, SSD: Crucial MX500 512GB, PSU: Enermax Triathlor ECO 550W, MOBO: MSI B350M Mortar
Mice: Zowie FK2 ScreenBenQ XL2411 144Hz MousepadHP Omen 300 XL KeyboardCM Storm Ultimate Cherry MX Brown My last.fm: http://www.last.fm/user/luky_

Server: Acer Aspire M1610, CPU: Intel Pentium D, RAM: 4GB, GPU: SiS IGPU, 60GB SSD + 160GB HDD, OS: FreeBSD, Manjaro Linux, Windows Server 2016, Services: Active directory, OpenVPN, Minecraft, Discord bots, Wake On Lan

Router: D-Link DVA-5592, Dual Band 2 Gbps, 5x Gigabit ports, 1x SFP, 1x xDSL Internet Link: PPPoE vDSL, DW: 201047 Kbps, UP: 21599 Kbps
My guides: Linux PCI GPU VFIO Passthrough,  Running X11 GUI WSL apps on Windows w/audio NO SSHBest gaming setup on Linux desktop and LaptopsSet up a OpenVPN Server on Windows

 

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, M.Yurizaki said:

Make sure after issuing "update-grub" it sees Windows. If it does, reboot and it should give you the option to choose.

 

It doesn't. Here's the output:

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-42-generic
Found initrd image: /boot/initrd.img-4.15.0-42-generic
Found linux image: /boot/vmlinuz-4.15.0-29-generic
Found initrd image: /boot/initrd.img-4.15.0-29-generic
Adding boot menu entry for EFI firmware configuration
done

 

Link to post
Share on other sites
4 minutes ago, mekkeron said:

It doesn't. Here's the output:


Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-42-generic
Found initrd image: /boot/initrd.img-4.15.0-42-generic
Found linux image: /boot/vmlinuz-4.15.0-29-generic
Found initrd image: /boot/initrd.img-4.15.0-29-generic
Adding boot menu entry for EFI firmware configuration
done

 

Apparently I forgot to add a step. After installing os-prober, do sudo os-prober then try sudo update-grub

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, M.Yurizaki said:

Apparently I forgot to add a step. After installing os-prober, do sudo os-prober then try sudo update-grub

No dice. Still getting the same output.

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, M.Yurizaki said:

Does the Linux install even see the Windows storage drive?

 

Yeah, both SSDs show up in Other Locations.

OS is the one that has Windows 10.

 

1889178793_Screenshotfrom2018-12-0712-57-14.png.108fa926ad8d2397c79c461442e0b671.png

Link to post
Share on other sites
Posted · Original PosterOP
2 hours ago, M.Yurizaki said:

Otherwise, you can, on boot, tell the system to boot from the Windows storage drive.

I see 

1st Boot Device [UEFI:ubuntu]

2nd Boot Device [Internal ODD Devices]

 

and then under Hard Disk Drives there is:

1st Boot Device - ubuntu

2nd Boot Device - UEFI OS (I assume it’s the Windows one?)

3rd Boot Device - ubuntu

 

So far changing the order of these didn’t seem to do anything. Still goes to Ubuntu all the time

Link to post
Share on other sites

You could use the efi entry instead to boot in Windows, also you could add the efi entry manually in grub too if you want some tweaking

 

also make sure to have the ntfs driver installed, and mount that partition while updating grub, make sure the efi partition is mounted too


Laptops: - Thinkpad x60S, CPU: Core Duo, RAM: 4GB, GPU: Intel 945M.  - Dell XPS 15 9550, i5 6300HQ, 8GB DDR4, Crucial MX500 512GB, GTX 960M
Desktop: CPU: AMD Ryzen 5 1600, RAM: HyperX 2667 OC 4x4GB, GPU: Zotac 1060 3GB Mini, SSD: Crucial MX500 512GB, PSU: Enermax Triathlor ECO 550W, MOBO: MSI B350M Mortar
Mice: Zowie FK2 ScreenBenQ XL2411 144Hz MousepadHP Omen 300 XL KeyboardCM Storm Ultimate Cherry MX Brown My last.fm: http://www.last.fm/user/luky_

Server: Acer Aspire M1610, CPU: Intel Pentium D, RAM: 4GB, GPU: SiS IGPU, 60GB SSD + 160GB HDD, OS: FreeBSD, Manjaro Linux, Windows Server 2016, Services: Active directory, OpenVPN, Minecraft, Discord bots, Wake On Lan

Router: D-Link DVA-5592, Dual Band 2 Gbps, 5x Gigabit ports, 1x SFP, 1x xDSL Internet Link: PPPoE vDSL, DW: 201047 Kbps, UP: 21599 Kbps
My guides: Linux PCI GPU VFIO Passthrough,  Running X11 GUI WSL apps on Windows w/audio NO SSHBest gaming setup on Linux desktop and LaptopsSet up a OpenVPN Server on Windows

 

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

Fixed it!!

 

It seemed that everything was pointing to the fact that the MBR on Windows SSD somehow got erased, so I was able to recover it by following these steps: https://neosmart.net/wiki/fix-mbr/#Fix_the_MBR_in_Windows_10

Even then I had go through additional steps outlined after "If bootrec utility doesn’t fix it..."

 

After that, I had to change boot priority in BIOS to get to Ubuntu (because after following the steps in the link I provided it defaulted it to Windows) and in Ubuntu, I ran the commands that M.Yurizaki mentioned sudo os-prober and sudo update-grub. It detected Windows right away and I am now able to double boot.

 

Thanks, M.Yurizaki and Lukyp for your help.

 

What a relief, I came very close to reinstalling Windows entirely.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×