Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

My computer knows the second monitor is there but doesn't display anything

PaulPaul
 Share

For over a year I have been using 2 displays for my PC, one is a fairly new curved samsung display that works with a HDMI from the monitor to the graphics card itself.

 

The second monitor is an older VGA monitor that connects to the motherboard by a VGA cable. Until today this set up has worked for years however when I turned on my PC today the second monitor is on but does not display the screen.

 

When I restart the PC, or pull the VGA cable out the light under the monitor turns orange to signify that it has no signal, however when powering on the PC or putting the cable back in the screen lights up but is black and the light turns green, it knows the screen is there but just wont show it. Nothing has changed and I have not done any updates. I have tried a new cable without success.

 

Please help!

 

I have a MSI GTX 1070 and the motherboard is an MSI Z87-G43

Link to comment
Share on other sites

Link to post
Share on other sites

Does the monitor work with any other type of input or any other computer? Could be that the backlight finally went out (Seriously, a vga only monitor? How old is that?)

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, corrado33 said:

Does the monitor work with any other type of input or any other computer? Could be that the backlight finally went out (Seriously, a vga only monitor? How old is that?)

Thanks for the reply, the backlight works as the screen lights up black, if that makes sense. It is just a random old one from my parents, better than no second monitor

Link to comment
Share on other sites

Link to post
Share on other sites

5 minutes ago, PaulPaul said:

Thanks for the reply, the backlight works as the screen lights up black, if that makes sense. It is just a random old one from my parents, better than no second monitor

Either could be a dead vga port on the card, or a dead monitor. 

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, corrado33 said:

Either could be a dead vga port on the card, or a dead monitor. 

Ok I will do some more troubleshooting thank you

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, ProRifts said:

Try pressing windows+p and then clicking extend.

The monitor wouldn't turn on if it wasn't currently extended or mirrored. (I do this all the time.) My monitor goes into sleep mode when I "unextend" my screen.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×