Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Windows 10 Black Screen Issue

Abhilash Mridha
 Share

Hey everyone, this is a weird one. Whenever I start up store it starts up perfectly.. no problem at all then I search for an app and then when I click install the screen goes black like it flashes a few times and if in that time I manage to close store it gets fixed but if I don't the computer goes unresponsive. I have to press the reset button in the end. I tried to use windows support but the same thing happens with that app as well. Initially I thought it was the problem with smart screen so I turned it off but the problem is still not fixed. I even reinstalled windows still not working. I am not able to install any app due to this. I think this happens whenever I open an app which needs me to login to my Microsoft Account but I am not sure. Some help will be really appreciated guys. Thank You.

Link to comment
Share on other sites

Link to post
Share on other sites

Maybe try creating a local account or sign into a different Microsoft account (create a new user account in the settings) and try to install the app on the new account? If that works then it might be a problem with the account. I would also try a clean installation if that doesn't work (wipe hard disk and install windows fresh or just delete all windows partitions and install) if you are okay with losing all data on the hard disk that isn't backed up if windows is activated with a digital license (I don't know much about product keys and how they work, it might remove the activation if its activated with a product key but someone could correct me here)

 

Edit: BTW don't try clean installing yet, someone else might have a different solution so do it as a last resort there isn't any more solutions.

Edited by Zethex
Some others might have a solution, so only clean install as a last resort
Link to comment
Share on other sites

Link to post
Share on other sites

When you both finish reinstalling and making clear installations (and deleting event viewer entries that may helps resolve this problem), then try to: not reinstalling system again, check hardware (ram for example - unplug one team stick and leave single for tests) and look at this event viewer before you decided to make another unnecessary system installation.

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, homeap5 said:

When you both finish reinstalling and making clear installations (and deleting event viewer entries that may helps resolve this problem), then try to: not reinstalling system again, check hardware (ram for example - unplug one team stick and leave single for tests) and look at this event viewer before you decided to make another unnecessary system installation.

TBH I have already tried a clean installation of windows didn't work... I think I mentioned this above. Anyways I tried clearing the event log didn't help.. there is no point in making a new account as suggested by the person above you because my windows won't be activated furthermore a local account does not allow you to download something from the store... Here is a recording of what happens when happens and how it happens. EDIT: There is no problem with the RAM I think I took it out and put it back in again... I have only 1 stick of 2GB DDR3 RAM.. if that helps.

Link to comment
Share on other sites

Link to post
Share on other sites

Do you tune up your windows somehow? Like disabling some services, change some registry entries, using special tools to block anything or change privacy settings?

 

Also - I don't recommend to clear even viewer. I recommend to stop reinstalling Windows or made clean installation because it makes even viewer clear! And event viewer is useful to find where problem is - all errors are displayed there.

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, homeap5 said:

Do you tune up your windows somehow? Like disabling some services, change some registry entries, using special tools to block anything or change privacy settings?

 

Also - I don't recommend to clear even viewer. I recommend to stop reinstalling Windows or made clean installation because it makes even viewer clear! And it's useful to find where problem is - all errors are displayed there.

LOL!!! rip event viewer..... I did turn off smart screen and also the windows update services. EDIT: Wait I just realized can it be because of the windows update service being disabled ?

Link to comment
Share on other sites

Link to post
Share on other sites

So turn on again Windows Update, BITS, Windows Defender Firewall (if any of them are disabled) and check again.

And check event viewer after that freeze - see what problem is reported.

Link to comment
Share on other sites

Link to post
Share on other sites

32 minutes ago, homeap5 said:

So turn on again Windows Update, BITS, Windows Defender Firewall (if any of them are disabled) and check again.

And check event viewer after that freeze - see what problem is reported.

Yeah all of them were off smh... did what you said still didn't work... opened event viewer.. this is what it said. 

Screenshot_5.png

Screenshot_6.png

Link to comment
Share on other sites

Link to post
Share on other sites

If Windows Defender Firewall was stopped, that means you tuneup something in your system or used programs that disables some functionality (like Windows Update or Windows Defender / Firewall). Microsoft Store needs / wants them to work (for some reason). Set these services to automatic mode and start all of them. If you're using some 3rd party tool to disable updates / firewall - use the same tool to re-enable it.

Link to comment
Share on other sites

Link to post
Share on other sites

37 minutes ago, homeap5 said:

If Windows Defender Firewall was stopped, that means you tuneup something in your system or used programs that disables some functionality (like Windows Update or Windows Defender / Firewall). Microsoft Store needs / wants them to work (for some reason). Set these services to automatic mode and start all of them. If you're using some 3rd party tool to disable updates / firewall - use the same tool to re-enable it.

I enable them they get disabled on their own.... I also found some other errors which were regarding some .dll files in system32 and I actually recall messing with some of them without creating backups (IDIOT!) so I guess I will have to reinstall windows.

Link to comment
Share on other sites

Link to post
Share on other sites

Just revert changes the same way you made this changes (probably by using the same tool you broke it). Or use sfc /scannow command (as admin) to check/repair system files (wow, this is first time I recommend that solution).

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, homeap5 said:

Just revert changes the same way you made this changes (probably by using the same tool you broke it). Or use sfc /scannow command (as admin) to check/repair system files (wow, this is first time I recommend that solution).

Thanks for your help bro.. it is fixed now :)

Link to comment
Share on other sites

Link to post
Share on other sites

23 hours ago, homeap5 said:

Just revert changes the same way you made this changes (probably by using the same tool you broke it). Or use sfc /scannow command (as admin) to check/repair system files (wow, this is first time I recommend that solution).

Umm... my windows updated and it started again.... I decide to get help using the "Get Help" app but as soon as the app started it also started to do the same thing. I asked someone on the microsoft forums but for some reason my post was deleted and I am not able to make a new post idk maybe I am paranoid. EDIT: one more thing some guy did reply to my post in the microsoft forum he told me to sign out of store sign back in. I did sign out but when I try to sign in it starts doing the thing.

Link to comment
Share on other sites

Link to post
Share on other sites

16 minutes ago, Abhilash Mridha said:

Umm... my windows updated and it started again.... I decide to get help using the "Get Help" app but as soon as the app started it also started to do the same thing. I asked someone on the microsoft forums but for some reason my post was deleted and I am not able to make a new post idk maybe I am paranoid. EDIT: one more thing some guy did reply to my post in the microsoft forum he told me to sign out of store sign back in. I did sign out but when I try to sign in it starts doing the thing.

Do you have official installer or some modified installer downloaded from "somewhere"?

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, homeap5 said:

Do you have official installer or some modified installer downloaded from "somewhere"?

Official Windows Update Assistant. This problem didn't exist in the old build.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×