Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

R9 270X clock speed problems

skypartan
 Share

Hi, i'm Lucas and I hope not to make any language mistake in this post (not a native speaker).

 

I have a Gigabyte R9 270X Windforce 2GB graphics card, and it keeps having problems all the time. I bought my pc around 3 years ago, and in the beginning I had no problems with it, with the old Radeon Catalyst drivers (if I remember the name correctly). Some time forward and AMD releases the new Crismon drivers, and the problems start. I used to play Battlefield 4 in good performance, almost no lag spikes or bad performance, until it all changed. The new version of the driver made most modern games unplayable, Bf4 now has constant lag spikes and low fps, and The Witcher 3 is unplayable at low quality with the slowest resolution. After a long time trying everything possible (clean driver install, windows reinstall, automatic driver installs, manual...), even going back to the old drivers (which worked perfectly in the past but now has a problem with overheating I have no idea why), I gived up and lived on with the fact that (in my head) AMD is really bad and I wasted my money on this product. Going forward in time, Destiny 2 becomes free, I start playing the game that magically runs on my computer with "good" performance at around 27 fps in the most intensive moments with a lot of stuff going on the screen. After some playing I try to record the game already knowing that my fps will drop drastically and won't be able to play, and that's exaclty what happens when I record with OBS, but, it just happened with OBS. Later I tried recording with the new windows built-in game recorder and... well, guess what, the exact opposite happened, my FPS increased, it almost doubled. In the exact moment this happened I already knew what has happening, and it goes back to that old problem I had.
Summaring what I've learned about this after a million tests: My graphics card has a problem with it's clock speeds, in any game I open, the clock goes up normal at around 1050mhz, stays a few secons, then drops back to 450mhz and stay. No matter what config I change in the game nor in the overdrive settings (Radeon driver config) the clock never changes, it always goes back to idle state, no driver version changes it. This happens with every game I try, some are playable even in this state (like destiny), but others are not.

What happened with the windows recorder is that, somehow, it  managed to boost the clock to it's full speed (1050mhz), giving much more power to both the game (hence increasing the game fps) and the recorder. I've even sent an email to AMD trying to figure out the cause of this issue but they had no answer. So, this is my last effort into trying to solve this problem before scrapping my graphics card, does anyone has an advice or guide or something that can help me?

 

My specs:

Core i5 4440

Gigabyte R9 270X Windforce 2GB

8GB ram

H81M-A/BR motherboard

1TB hd

240GB ssd with windows (this one is recent)

 

I don't have any overclocks or tools like afterburner installed.

 

 

Note: I would like to investigate this one further. My whole pc turned off after a few seconds recording the game (with both destiny and battlefield) with the windows software, I still don't know if it's a problem with the recorder or if it's my gpu dying.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×